Subscriber page nr in database changes after sending message


I still wonder why you cannot change the subscriber page in the settings of the subscriber. I use three subscriber pages, but after sending a message, the nr of the subscriber page is set to 1 (default) in the database. Weird!
I have subscribers in two different fields of interest and I offer them a different subscriber page. But if the nr of the subscriber page changes in the database after sending a message, they cannot change their preferences because the wrong subscriber page is presented.
Second, how can I use two different languages for two different groups??


Can you tell me

  1. what version of phpList you are using
  2. specifically the problem, step by step like a) I make subscribe page b) I send mail etc.

I will then try to reproduce this. Could be a bug, sounds odd so far, but your info isn’t quite clear enough for me to be sure :slight_smile:

Hi Anna,
Thanks for your prompt reply.
1- I have three subscription lists and I use subscription list nr 3 to enter a subscriber to that specific list.
2- I create a message and do a 'test send 'to check the message.
3- After that, I check the subscription list of the subscriber, and I see that the list nr has changed form 3 to 1 (default list).

I had to change all my subscribers (who subscribed to list 3), because the list nr had changed from 3 to 1 after a mailing.
This change of list nr has to be done in the database directly, because there is no way to do it otherwise (at least not to my knowledge).

Hope this is clear to reproduce this error.


PS I use the latest version of PhPList (3.2.4)

Ok, so break this down some more. How exactly to you enter the subscriber? which menu items do you click? Feel free to add a screenshot


Previously you referred to “subscriber page”, not “subscription list”. Your explanation is a bit confusing because you seem to be using different terms.

Okay, sorry I mixed up things (that is what you get working after midnight and use a foreign language).
Screenshot 1:

Page 1 is the default page and related to audio lists.
Page 4 I use for english readers and is related to something completely else than audio.

People who subscribed with page 4 have in their subscriber profile:
Which page was used to subscribe 4
(I had to remove the image because I’m a newbe…)

So far so good.

Now, I prepare a campaign and send a test message to the subscriber. If I check afterwards the subscriber’s profile, I see that the subscriber page has changed to 1.
Also when I send a campaign, all subscribers have their subscribe page set to 1.

Hope this is better to follow.

My second remark is that you cannot change the subscriber page of a subscriber’s profile other than through direct editing the database! And that is a lot of work.

Also manually entering new subscribers (as admin) can only be done by using the right subscriber page per new subscriber. After saving the subscriber you have to go through the menus and start again with the next new subscriber.

Sorry for putting three subjects in one post, but they are related and I’m a bit annoyed that I cannot move on with my campaign.

Hope a solution comes forward from this post.


ok, I am going to work on replicating this - this is wrong, it should not be like this.

OK, I can’t replicate. I upped your forum rating, see if you can add more images now to show me the issue

Fine, in pictures now.

subcriber’s profile before sending test mail

result of sending test mail

subscriber’s profile after sending test mail

Subscriber’s profile subscribe page has changed from 4 to 1. You can also see that the parameter is modified, look at the date/time stamp.
Now I have to edit my database manually to get this parameter back to 4.
I guess this is not a feature…


I found the history log that you might find useful:

@Ronald I wonder whether something such as spam/anti-virus checker is “following” links in the email. What links are in the email, the URLs?
Also if you view the header of the email there will be some headers similar to


What are the values for those URLs? They should be the values in the Subscription settings group on the Settings page.

Trying to understand why the problem happens I was wondering if my database is correct According with the function in phplist is it okay.
But looking at the tables, I wondered why I have different table prefixes? phplist_ and plist1_ .
I believe that phplist_ is from an older version.

From prefix phplist_ only these tables hold information:
Information in these tables is up-to=date.

These tables do not exist in prefix plist1_ except for plist1_urlcache.
So the program uses two different prefixes which does not seem right to me.

How to correct this?



Yes that lookes okay:

X-PHP-Script: for 47.6xxxxxxx
X-Mailer: PHPMailer 5.2.14 (
X-phpList-version: 3.2.4
X-MessageID: 32
Precedence: bulk
MIME-Version: 1.0
Content-Type: multipart/alternative;
X-Authenticated-Id: vanovost

I think it should say: List-Subscribe: (Also for unsubscribe)
Or maybe the unique userid.
If the list is not indicated, the default list will be used.

But maybe my database not correct (see preivious post)?


This section in config.php defines the table prefixes

# if you want a prefix to all your tables, specify it here,

$table_prefix = "phplist_";

# if you want to use a different prefix to user tables, specify it here.
# read README.usertables for more information

$usertable_prefix = "phplist_user_";

I guess that yours are

$table_prefix = "plist1_";
$usertable_prefix = "phplist_";

That does seem to work but I would make them consistent and rename tables to match.


Hmmm, I have in config.php: $table_prefix = “plist1_”;
That’s all. So I’m confused how this can work in the first place?

Is there a safe way to make ik consistent?
The first step I know: make a backup. But how from there?


What is the background to this? I got the impression that it is a new installation of phplist but that does not look to be the case.

I suggest exporting all of the subscribers, then installing phplist with a new database, and then import the subscribers.

Yes, that might solve problems like the one reported.
I use it for a couple of years, so upgraded from time to time.
Maybe starting from scratch (with the existing subscriber information) is a good idea. Also a lot of work and I loose my statistics I guess?
I have to think about it, right now I cannot use it the way I want it.
But I don’t see how I get the data from the old database in a clean new database, since database tables are also part of the backup.

Dinner time here.



Here is an update. I made a backup of the database, deleted the old phplist_ prefix entries and renamed/edited the missing ones like …
to plist1_ etc.

Then I’ve deleted all tables in the database and imported the edited data. That worked, but the user data was missing. So I let phplist fix the database and I saw that the missing tables were created but with the phplist_ prefix.Damn! Why is that? In my config.php I have $table_prefix = “plist1_”;

Does anyone understand what is going on?

PS What are these tables for (pma__ )?

As I pointed out earlier there are two lines in config.php that define prefixes for tables, you should set both and ensure that they are consistent.

Good morning duncanc,
The default config.php doesnot have a prefix set. The extended config says:

  • if you want a prefix to all your tables, specify it here,
    $table_prefix = ‘phplist_’;

  • if you want to use a different prefix to user tables, specify it here.
    read README.usertables for more information
    $usertable_prefix = ‘phplist_user_’;

So when I have $table_prefix = 'plist1_ '; then ALL tables should start with this.

I learned that phplist, when checking/creating tables, uses phplist_ as a default, not taking my setting in config.php into account. Now that I understand this, I can live with this small bug.
I have put my backup back in place and move on investigating the original problem of phplist changing the subscriber page setting in the subscriber profile after sending a message.


You do realise that phpList ONLY uses config.php, not config-extended.php? To use the settings from extended you have to copy them into config.php file. :wink:

1 Like