back to phpList.org

[SOLVED] Unable to extract error log while debugging SMTP


#1

Hello. I have been scanning forum posts about this back til 2007 and have still not been able to figure it out so please forgive if this question has already been asked and I am being stupid.

I am using phplists on a shared webhost where I cant access /var/logs/access.log and error.log, So far its been all good but I recently had to switch to an external SMTP and im getting a SMTP connect() failed. The same config with the same smtp works on my localhost and on another webserver I have access to and my host swear they are not blockign any ports etc. So I am trying to debug to get a better idea of whats going on.

I have so far tried the various options related to define(‘PHPMAILER_SMTP_DEBUG’, ); but I can’t figure out where the errors are supposed to appear. I get no text on the screen. No email and nothing in the event logs.
Am I just being very dumb or is there a problem? Thank you very much for your help!


#2

I have no experience debugging the smtp portion of PHPList, but might I suggest you go into wherever it outputs errors and have it output to a different file than access.log or error.log? It’s a manual fix, granted, but it’s a potential work around for your problem since you use a shared hosting account.


#3

Hello and thank you for the reply.
Yes this is also a thought that crossed my mind. So I went and tampered with class.smtp.php in admin/PHPmailer/ and changed public $Debugoutput to html, and then to echo. and I’m still not getting any errors anywhere.


#4

@KhaledBey Add this to your config.php file

define(‘PHPMAILER_SMTP_DEBUG’, 2);

Then when composing a campaign send a test email. The debug output is at the top of the page


#5

Hello Duncanc. Firstly, thank you for your many helpful answers in this forum. Your help to others have helped me with a couple of problems that popped up in the past : )

Now to my problem. What you tell me at least confirms that I have not completely lost it.
Even though I have used the define(‘PHPMAILER_SMTP_DEBUG’, 2); in my config.php. I am not getting any text at the top of the page. Nor on my live setup, on my local server or even with a fresh install on my local server.

I don’t really have any explanation to this.
Am I doing something wrong when adding the argument to my config.php file? I doubt it, since its not the only argument I have been tampering with…

Or can it be a browser issue? is my browser somehow blocking the server messages?


#6

Dah!
Turned out adblocker was blocking the messages.

Thank you so much for your help ! Now I’ll proceed in debugging this SMTP server :smile: