PHPList 3.6.3 Updater Bug

There is a bug when running the updater from 3.6.2 to 3.6.3. When phplist 3.6.3 is downloaded to tmp_uploaded_update, it is downloaded to directory phplist-3.6.3. The trouble is the updater expects the the directory to be tmp_uploaded_update/phplist NOT tmp_uploaded_update/phplist-3.6.3.

Resolution: The updater says “Downgrade is not supported” until tmp_uploaded_update/phplist-3.6.3 is renamed to tmp_uploaded_update/phplist

(I couldn’t figure out how to create an account on Manits)

3 Likes

@cschmitt The updater hasn’t changed in a while, this looks to be an inadvertent change to the top level directory in the download file. As you say, the updater expects it to be “phplist” but is now “phplist-3.6.3”.

@mariana Do you know how to revert the directory name in the zip file? The updater code expects it to be simply “phplist”, e.g. line 527 of updater.php

    $rootDir = __DIR__ . '/../tmp_uploaded_update/phplist/public_html/lists';
1 Like

When we are in the screen “Downgrade is not supported” I have renamed the folder phplist-3.6.3 to phplist (inside the temporary folder “tmp_uploaded_update”, and then clicked next in auto update.

the upgrade was successful.

2 Likes

Thank you worked like a Champ.

1 Like

Thanks for reporting. Someone already created a GitHub Issue to report it:

Workaround works like a charm - thanks! :+1:

1 Like

Thanks for posting - your workaround worked for me.

I have changed the folder as suggested, but get a blank dashboard after “upgrade”.

I see that the Github was closed. It is installing now, but then I get a blank mydomain/lists/admin/?page=home. I have tried on different browsers, and the same issue.

I was running my server on PHP8. 3.6.2 was running on this just fine. Now downgraded back to PHP version 7.4 and now it is working with 3.6.3. What else changed?

@Seahawk see this topic regarding phplist not yet being supported with php 8 PHP 8 not supported yet

1 Like