back to phpList.org

KCFinder shows no image


#1

Hi,
my KCFinder shows just empty page like this, when I try to upload images.

define(“UPLOADIMAGES_DIR”,"_media/news");

is correct nad I can upload new images via Send tab.
I use latest phplist 3.3.8, before upgrade from version 2 it worked fine…


#2

@Kudykam Can you use the developer tools in your browser to look at the http requests. Possibly one of the kcfinder files has not been requested successfully.

Also, note that kcfinder will be looking in the _media/news/image directory for image files.


#3


what does it mean?


#4

@Kudykam It looks to be a javascript problem. Which browser are you using, and can you try a different one?


#5

Chrome / Firefox - same results…


#6

@Kudykam I guess that something else must be failing before that, otherwise the problem should occur for me too.

But you can try modifying one file
at line 20 of file admin/plugins/CKEditorPlugin/kcfinder/tpl/tpl_javascript.php
Insert the middle line below. That doesn’t have an adverse effect for me, but might resolve your problem.

_.version = "<?php echo self::VERSION ?>";
_.support = {};
_.support.zip = <?php echo (class_exists('ZipArchive') && !$this->config['denyZipDownload']) ? "true" : "false" ?>;

#7

Thanks, but it didnt help. Its definitely not computer/browser related. It doesnt wokr on 3 different computers.
Phplist its not clean installation but after many upgrades.


#8

What did you mean by this? Have you only now upgraded from phplist 2? Have you tried using the fckeditor, you can enable that on the Plugins page.

You can send me a private message with the phplist access details so I can take a look, but otherwise I don’t really have any suggestions.


#9

I would send you PM, but I dont know how… Dont see any option anywhere…
thanks.


#10

@Kudykam Just click on my name or image.


#11

I had the same problem. I needed to change the file permissions on the folder so that the server could read it.


#12

I know that, but there is no messages… Maybe I dont have sufficient rights…


#13

What folder? All seems to be 755 of 644 for files…


#14

BTW, I found out that sending newsletters also doesnt work…


#15

Can you see this when you click on Duncan’s name/image?


#16

I suggest that you re-install the phplist code.


#17

I had to create the folder /uploadimages in the root directory and change its permissions to 755.


#18

No, I dont have this button…


#19

I have this folder, eventhough in settings I have different folder for images…


#20

How should I do that? I just rewrite all files in root (same version). In admin, there is no upgrade or setup button…