back to phpList.org

Code from Responsive Email Designer is being sent as text not HTML


#1

New user here, just testing this out as a possible replacement for my current e-mailer. I do my design work in CoffeeCup Software’s Responsive Email Designer, and use the responsive code it generates for my emails. Everything looks fine in phpList’s editor when I paste the code in, but when I actually send the message it’s converted to text and not displaying the HTML.

Now, if I manually compose a message in the HTML editor used by phpList, that is delivered as HTML. But there’s no way I could use that for content layout, it’s too rudimentary.

Any suggestions on how to get around this issue? Thanks in advance.


#2

@bcarney if you do not intend to use the phplist editor then you can disable the ckeditor plugin on the Manage Plugins page. After that, when composing you will have a text area into which you can paste the raw html.


#3

I turned off that plugin and the content is still being sent as plain text. I suspect it’s something to do with the code I need to paste in - it’s a full HTML page, with head section etc.


#4

I also tried this option mentioned in the help button next to the Compose Message label (with the path obviously changed):

To send the contents of a webpage, add the following to the content of the message:
[URL:https://www.example.org/path/to/file.html]

but that didn’t work either, it just sent an email with “[URL:https://www.example.org/path/to/file.html]” as the content, not the page itself.


#5

@bcarney ensure that the subscriber has the option of receiving html, not plain text, emails, on the subscriber profile page
image

and that you are sending an html email, not plain text. on the compose Format tab
image


#6

I double checked, and both those are marked correctly.

Something is changing the code somewhere between steps 1 and the actual sending. Here is a link to the HTML that I’m using:

https://1drv.ms/u/s!AmEFZaZ67kD-iO4SjD7Gg0nfCehmNg


#7

@bcarney One other possibility. Are you sending a test message? If so, then by default phplist will send two emails, one html and another plain text. So you might be looking only at the plain text version. If you haven’t received the html version then it might have been treated as spam or junk.

Using your sample html, pasting into the source view of the phplist editor, works ok for me.


#8

I’m not sending them as test messages, I created a list with a couple of my personal emails in it and have been sending to that (so as to learn the software).

The code looks like that image in the editor, but once it’s sent and viewed in the inbox, it’s converted to text.


#9

I enabled curl and tried to use the Content: Send a Webpage function, and it too was sent out as plain text. This happens when using the Send Test function as well as when sending the campaign.


#10

@bcarney The email sent by phplist is being truncated.

The content type is correct
Content-Type: multipart/alternative;boundary="b1_724d223e149e24be901b583d5154dfd3"

but the email just stops near the end of the plain text part. That is not closed correctly, nor is the html part included.

It looks to be the same problem as reported at If the last character of the footer is a DOT, then DKIM FAILS... WHY?
In that case the cause seemed to be the Exim mail package but I cannot tell whether your server is using that.


#11

I did some more testing, using other newsletters composed in Responsive Email Designer. About half wind up going out in HTML, and the others revert to text. I can’t tell for sure, but it appears smaller amounts of code appear to go through OK, and it’s the more complex newsletters that flip to text.


#12

It is caused by a dot character appearing on a line on its own. That can easily happen when you have a link followed by a full stop. As you have click tracking enabled, that generates a long URL which often forces the following text to move to a new line.
When that text is only a dot then that appears to hit a bug in Exim.

You can try increasing the line length, as explained in the linked topic to try to stop the dot character being moved to a new line. Or change the encoding to be 8-bit in config.php

define('HTMLEMAIL_ENCODING', '8bit');

#13

Hmmmm, I’m using Axigen as my mailer, and it works with my other emailer (Interspire’s Internet Email Marketer) using the same HTML code.

I tried

define('HTMLEMAIL_ENCODING', '8bit');

and that made no difference, unfortunately.


#14

Just to try to confirm the cause can you remove the full-stops that are immediately after a link. There are only four of them

website</a>.
www.michigan.gov/dnrdigests</a>.
www.mdnr-elicense.com</a>.
www.michigan.gov/MiMorels</a>.

#15

I removed the periods and then sent the message to me. At first I mistakenly left the default footer and the message arrived blank (except for the footer, which was in HTML). When I deleted the footer text the message still arrived blank, except for the Powered by phpList image.


#16

I just sent a copy (which will likely be blank) to your phplist@ address. As a reminder it will come from an newsletters@ address.


#17

@bcarney I haven’t received the last campaign that you sent.


#18

Just sent it again with the subject line “test no periods”.


#19

I haven’t received either of the emails, and they don’t appear to have been flagged as spam.


#20

Just to confuse matters, I copied and pasted your source code into my phpList installation and sent it as a test email, come perfectly.