CKEditor tool bar is not showing up

I just downloaded PHPList 3.0.12 and the FCKEditor didnt not show up. I read all the blogs, FAQs etc and have tried everything suggested. I also read that FCKEditor has been replaced by CKEditor. So I down loaded CKEditor from the Config/Manage Plugins and still didn’t have any luck. Then I noticed that there was a newer version out there and downloaded the 4.4.7 version of CKEditor. Still no toolbar. I have checked my paths in PHPlist and the config files and nothing seems to work. I even modified the paths in the Config/Manage Plugins to verify I had them correct and when I did the modifications, I got an error, which is what I expected. So I set them back to what there were and now get no errors but the tool bars don’t show up. It has to be something very simple but I have spent 15 hours on it already and at my wits end. Any help would be appreciated.

You didn’t mention having enabled either of the editor plugins. Did you do that?

Otherwise what value do you have for “Path to ckeditor” on the Settings page?
In your config.php file what value do you have for the plugins directory

define("PLUGIN_ROOTDIR", ...

You can also use your browser tools to look at the http requests made when you edit a campaign. Most likely there will be a request that returns 404 - “not found”. The url that is being requested should provide a clue as which setting is wrong.

In Firefox use menu tools > web developer > web console.

Duncan, thanks for the quick response. Yes, In “Settings/Manage Plugins” CKEditor is enabled and FCKEditor is disabled. Since I am a new user to Discuss, I cant attach any screen shots. I have jpgs of the Manage Plugins, Config/Settings page, the directory structure for the website, and the Config.php file if there is a way to get them to you. Plug in directory is:

When I look at the console, it seems to run down to line 113 with out a problem and then I get an error at line 114. “CKEditor is undefined”. Below is the console starting with line 112: (I have only noted lines 112-114 only)
112 value=“e.g.” size=“60” />

Compose message?
</ So I guess something is not pointing correctly Hopefully you can direct me to what needs to be changed and to what.

Also in watching the console, every time I would move from one page to another I would see this message:
"Failed to open HTTP://"
but then it moves to the page I had selected. Don’t know if that is of any significance but thought I would share it.

Your value for the plugin directory looks wrong. It should be a file system path, not a web path. Or relative to the phplist admin directory, which is the default value of “plugins”.

But I am not sure why the installation appeared to work if it is wrong.

On the Settings page what is the setting for “Path to ckeditor”? That is a web path or relative to the phplist admin directory (which is the default value).

Changed the Plugin Rootdir to:
with no errors when I start up a new campaign.

In the Setting page the path for the CKEditor is:

Here is what I see in the console when I start new. This starts on line 114
"CKEDITOR.replace(‘message’, {
allowedContent: true,
filebrowserBrowseUrl: ‘/phplist/admin/plugins/CKEditorPlugin/kcfinder/browse.php?opener=ckeditor&type=files’,
filebrowserImageBrowseUrl: ‘/phplist/admin/plugins/CKEditorPlugin/kcfinder/browse.php?opener=ckeditor&type=uploadimages’,
filebrowserFlashBrowseUrl: ‘/phplist/admin/plugins/CKEditorPlugin/kcfinder/browse.php?opener=ckeditor&type=flash’,
filebrowserUploadUrl: ‘/phplist/admin/plugins/CKEditorPlugin/kcfinder/upload.php?opener=ckeditor&type=files’,
filebrowserImageUploadUrl: ‘/phplist/admin/plugins/CKEditorPlugin/kcfinder/upload.php?opener=ckeditor&type=uploadimages’,
filebrowserFlashUploadUrl: ‘/phplist/admin/plugins/CKEditorPlugin/kcfinder/upload.php?opener=ckeditor&type=flash’,
width: 600,
height: 600
X CKEditor is undefined - This is the error message.

In PHPList there is no errors on the screen when starting a new campaign.
Hopefully this gives more information.

Here is the directory structure of the website, just in case it might be helpful.

I’m not sure what you are looking at when you refer to line 114.
What I asked previously was to look at the http traffic to find a 404 not found.
There should be a browser request for the file ckeditor.js. That file is not being loaded which seems to be the problem.

There may be a more complex explanation but this is often caused by

  1. Internet Explorer or
  2. a firewall, addblocker or virus checker

Sorry, I am a newbie at this. What I sent was what was displayed in the debugger window when I was running the console as you suggested when starting a new campaign. The console window showed “SCRIPT5009: ‘CKEDITOR’ is undefined” as the error. No 404 errors. Also no messages on the “Send a Campaign” page regarding an error or that they could not find the java script file.

What do I need to look at to investigate the possibility that IE or a firewall etc. problem?

Are you using Firefox? if so, then that window has a number of tabs along the top - Inspector, Console, Debugger …
On the Console tab you can see the http requests from the browser. If you navigate to the Compose tab in phplist then you should see the http requests. Possibly you might have to hit F5 to force a full refresh of the phplist page, but then there should be a request for ckeditor.js. You need to see what the requested url actually is.

  1. Try it in a few different browsers, does it change.
  2. If you have a firewall or anti-virus, disable it for few moment and see if it changes

I am in IE 11. In the console, when I try to launch a new campaign, it gives me a message that says:
HTML1300: Navigation occurred.
HTML1524: Invalid HTML5 DOCTYPE. Consider using the interoperable form “”.
SCRIPT5009: ‘CKEDITOR’ is undefined

I don’t see a request for ckeditor.js or any URLs or anything like your attachment. Where should CKEditor be defined?

Are you able to use a different browser - firefox or chrome? I don’t use Windows so am not able to confirm whether there is a problem using IE11.
But it appears that the debugging window that you are using does not provide a view of the http requests, or at least you cannot find it.

I just fired-up a Windows 7 laptop that has IE 10. This is what the Developer Tools looks like. Hopefully it is similar in IE 11.

CKEditor is defined in the file ckeditor.js that should be requested when you go to the phplist campaign page. As both fckeditor and ckeditor both don’t work for you then I guess that there is a problem in loading that file, and a similar one for fckeditor, rather than a direct problem with either plugin.

ok, now I see you are looking at the network tab in the developers tool. So I opened up the Network tab and turned on the recording. and the last call that it made was trying to find the ckeditor.js file on my C: drive. Below what was on the console:


Yes, the last line was duplicated. So where would this call be coming from?

I don’t understand this at all. The last two lines are referring to a temporary directory used when installing the CKEditor plugin.
But I can’t tell whether that directory is on your local PC, or on the server. Is “Sindie” your local windows account or your account on the server?

I suggest removing phplist entirely, drop the database and install it again.

ok, I will try reinstalling. BTW, that is referring to a path on my hard drive.

Reinstalled PHPlist and CKEditor. Now I am getting a 404 error in the console. I have tried several different configurations of the path to ckeditor.js but nothing seems to work.

Please provide as much information as you can. Just saying that it is still not working doesn’t help much. If you are using the default settings then you shouldn’t need to change anything.
Please show the settings that you are using for

  • the plugin directory in the config.php file
  • $pageroot in config.php
  • the “path to ckeditor” on the settings page

and the actual url that is shown with the 404 error on the console.