CAPTCHA plugin doesn't show up into subscribe page

I’ve got a PHP List 3.6.7 installation on a Windows IIS+PHP+MySQL server since years.

I need to install the CAPTCHA plugin (plugin:captcha [phpList Resources]). I followed the instructions:

  • I installed the Common plugin (“phplist-plugin-common”) and enabled it
  • I installed the Captcha plugin (I can successfully modify the options from PHPList)
  • I installed SecureImage too, modified the secureimage.php file as asked (public $session_name = ‘phpListSession’:wink:
  • I enabled into PHPList > Config > Subcription pages > the options “Include captcha in the subscribe page” and “Do not validate captcha for asubscribe”

but the captcha doesn’t show up, as you can see here:

I also tried to subscribe one of the top 500 email as test (picked from: Stop Forum Board > DataTable). I expected to do NOT have the user subscribed, but it subscribed as nothing was configured.

What’s wrong?

Thank you for your help and support!

@ilnebbioso Look at the Event Log page for any error that might have been reported.
Possibly Path to the securimage directory is incorrect.

@duncanc thank you for your prompt reply.

The Event Log page reports only old events. Nothing since I installed the plugins.
Path: I both tried “/plugins/securimage/” and “/plugins/securimage” without success.

Securimage is in this path, from root.

@ilnebbioso Can you look at the subscribepage_data table to see whether there are rows with a name field value like “captcha_”. If not then please edit the subscribe page and click the “Save changes” button.

Please take a look to this. Isn’t already done?

@ilnebbioso There is a bug in the code. If you didn’t actually click the “Save changes” code then the include captcha field was never set to enabled.

I already saved this!

@ilnebbioso What is the value of Path to the securimage directory on the Settings page?

Sorry you explained that previously.

What did you mean by “installed the plugin”. The plugin is now part of phplist so you should not have had to install it but only enable it on the Manage Plugins page.
What is the path /plugins meant to be containing? Plugins should be in the admin/plugins directory.

You’re really welcome, @duncanc ! Don’t worry!

You will see here:

  • the path /plugins/securimage/ path on server


You will see here:

You will see here:

  • the plugin I’m using.

@ilnebbioso So in config.php you have changed the value of PLUGIN_ROOTDIR ?

Can you change that back to the default value, which is "plugins";
Both the Captcha plugin and Common plugin are in the admin/plugins directory along with a few more. I’m not sure why this might cause a problem but I would like to rule it out.

This is the php code that determines the location of the securiimage code. Can you see why that might be a problem, possibly only when using IIS?

    private function captchaEnabled()
        $path = trim(getConfig('captcha_securimage_path'), '/');

        if (!file_exists($f = rtrim($_SERVER['DOCUMENT_ROOT'], '/') . "/$path/securimage.php")) {
            logEvent("securimage file '$f' not found");

            return false;

        include_once $f;

        return true;

An event log entry should be written if the securimage.php file does not exist, otherwise that file is included.

This is my PHPLIST config.php file (unchanged since months)

@duncanc where should I copy/paste the code you sent to me?

@ilnebbioso Can you give me temporary access to take a look?

You can add a new super admin with this email address

Done. You received an email.
You can only “Change settings”. Is this enough?

@duncanc I’m not so sure.

The “securimage” folder should be into:

  • /plugin/securimage or
  • /admin/plugins/securimage folder?

Actually I copied in both folder, but until today it was only into the first one.

@ilnebbioso The first should be ok.
I have not received the password change email yet. Please can you resend that by editing the admin, select the “Update it” radio button for the Password field, then “Save changes”.

@duncanc I just done it!

Ok I removed the /admin/plugins/securimage folder!