After installing 3.0.12 I have 30 sec pause after every batch

Hi, after installing 3.0.12 I have suddenly 30 sec pause after every batch and I cannot find where to change it in the config. Thanks for every hint…

You don’t give any info about which version of the config file you are using, if you are using the quick start (default config.php) file, then you need to add the following from the config_extended file into your config.php file:-

> # define the amount of emails you want to send per period. If 0, batch processing
> # is disabled and messages are sent out as fast as possible
> define("MAILQUEUE_BATCH_SIZE",0); 

> # define the length of one batch processing period, in seconds (3600 is an hour)
> define("MAILQUEUE_BATCH_PERIOD",3600);

> # to avoid overloading the server that sends your email, you can add a little delay
> # between messages that will spread the load of sending
> # you will need to find a good value for your own server
> # value is in seconds, and you can use fractions, eg "0.5" is half a second
> # (or you can play with the autothrottle below)
> define('MAILQUEUE_THROTTLE',0); 

Set the first value to either “0” or the number of emails your host allows per hour.
The second value is the number of seconds for each batch (3600 is an hour)
The third value can be used if you need to set a delay between sending each batch, and is the one which is causing a 30 second delay for you.

Hi dragonrider,
thanks for responding. Sorry, yes, I am using the extendet version of the config, thats the main reason that I am so irritated. In the Moment the config contents:
# define(‘DOMAIN_BATCH_PERIOD’,120);

Have you renamed config-extended.php to config.php? phpList only works with the one file called config.php

yes. and it worked well before the update to V 3.0.12!

Ok, thanks for clearing that up.

From your settings it looks like you are sending 200 mail per second, have to ask, what are the limits imposed by your host please, if any.

phplist now has a gap of 30s between sending batches when processing the queue through the browser. In previous releases it waited for the batch_period, usually much longer, which might be why you have set the batch period to 1s.

To have greater control over how phplist sends you need to use a cron job. Your settings suggest that you want to send as fast as possible, so use a cron job to achieve that.