Your PHP version is out of date

Hi, since I upgraded to 3.3.1 my installation of phpList basically stopped sending out messages. At least not unless I keep “kicking” it. I had a CRON job setup which worked forever, now, it says my PHP version is incorrect. Phpinfo reports 5.4.45 and PHP_VERSION when I write it out says the same. However, in admin/index.php on line 491 I get the php version error. I’m stuck, and my mailing is not going out. Does anybody have any ideas?


Istvan Siposs

Is there any way to “downgrade” to a lesser version of PHP list? Not even manual processing works. It sends a handful of messages then instead of reloading it just stays there and finally times out, so I have to log back in , and click “Process Queue”. Then it sends another handful, etc.

Looks like for whatever reason it started working after a complete re-install, but now it sends out exactly one email each time the CRON job runs…

What are your batch settings in config.php? If you enable VERBOSE then there will be more information in the event log page which might explain what is happening.

I figured if I could somehow figure out why it’s complaining about the PHP version then I should be able to fix the issue. So this is pretty weird, if I run phpinfo() or print out PHP_VERSION, they both show 5.4.45 . However, if I leave WARN_ABOUT_PHP_SETTINGS as 1, then my CRON job returns with this:

phpList version 3.3.1 © 2000-2017 phpList Ltd,

Error: Your PHP version is out of date. phpList requires PHP version 5.4.0 or higher.

And this is coming from admin/index.html, line 490:

if (version_compare(PHP_VERSION, ‘5.4.0’, ‘<’) && WARN_ABOUT_PHP_SETTINGS) {

And to add to the weirdness, I tested just this:
version_compare(PHP_VERSION, ‘5.4.0’, ‘<’)

and to me this returns 1 , whereas according to the version_compare documentation if you specify the operator then the function should return TRUE or FALSE . So that explains why the condition fails here, but does this mean that perhaps there is a problem in the PHP that’s running on my server?

@isiposs Earlier you said that things were working after reinstalling.

Change the error message to include the php version, possibly it is different to that used by the web server.
Also if you disable WARN_ABOUT_PHP_SETTINGS then this problem should be ignored, but you might hit other problems.

It has the correct version (5.4.45) but apparently version_compare returns a number rather than TRUE or FALSE as it should when the comparison parameter is provided… I did try turning WARN_ABOUT_PHP_SETTINGS off yesterday but then, as you said, I ran into other problems. Like if I processed the queue from the browser it never refreshed, and if I let the CRON job do it, then it only sent one message at each run. Not sure where to take it from here. Is there any way to “downgrade” phpList to an earlier version that does not require PHP5? Everything worked great before I upgraded to the latest.

I installed 3.2.7 back over 3.3.1 and that works (it has before). But I think it doesn’t require PHP5.

You might also have tried to update your php on the server. how you do that depends on what kind of host you have, the o/s, o/s version, and whether you have access to the command line, or not.

The host has a PHP Selector tool right in Cpanel, so I picked the correct version there…

Here’s a response from our host (A2) that explains why we can’t install phpList via cPanel, even though the server shows as 5.5. We get the message that phpList needs 5.5 and the installer is running on a server is 5.3.27. Not sure if this helps, but there you go.

Hi, Thanks for getting in touch with us. We do apologise that this causes confusion, please let us explain why this is. Currently as we use CloudLinux as out main operating system, this comes with a hardened PHP Selector (The Blue and white icon in cPanel). The current versions of Softaculous cannot check what versions of PHPO are selected in this environment so effectively it falls back to the internal Softaculous default configuration version of php 5.3. We do apologise for this but currently this is a bug outside of our control. phpLists can however be installed manually if you so wish using the following downloads: The installation instructions are quite straight forward for this application. If you would like to contact us about anything further, please do not hesitate in getting in touch with us. Kind Regards Jeff W.

Hi Bill, I actually got past that point doing the manual install, but that’s when I ran into these other issues. The CRON job reporting that I didn’t have the correct PHP version even though everything else says I do, and once I turned those PHP setting warnings off, then it would only send one email at a time… I then re-installed 3.2.7 and that solved everything. It’s now working like it did before although I now have an older version…