WYSIWYG Editors arent allowing for image uploads or browsing


I have been working on developing my campaign templates, but im having a problem with the image managers. For example:

  1. CKeditor is the default editor for PHPLists. When I want to upload or browse for images, the dialogue window states “not logged in”. I cant get any further
  2. Because of the issue with CKEditor, I installed TinyMCE. When I click the icon to upload or browse for images, it opens the elfinder attachment for TinyMCE and says it cannot connect to the back end. Once again I can go no further. I checked the settings and the path to elfinder is correct.

Atthis stage I’m lost. can anyone tell me why the editors cannot allow for the browsing of images? seem as t hough this is a PHPList problem as now there are two editors with the same issue.

@jeddell “not logged in” means that there is a problem with the php session. kcfinder is not using the same session as phplist. Have you changed any php session settings?

I’m going to say no to that questions, but purely because, I wouldn’t know how. I’m the sort of person that installs and hope it works straight out of the box, sets things up from video tutorials, then searches forums for solutions to problems.

I’m guessing there is a way to check?

@jeddell If you enable Common Plugin on the Manage Plugins page there will then be a menu item Config > phpinfo.

Look for session.auto_start, I think that it needs to be set to “Off”.

Thanks for the reply. Yep checked that setting. Definitely set to “off”.

Anything else to check?

@jeddell These are the values on my phplist. Some differences will not be significant though.

What is your environment, server etc?

Directive Local Value Master Value
session.auto_start Off Off
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_httponly 1 no value
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_samesite Strict no value
session.cookie_secure 0 0
session.gc_divisor 1000 1000
session.gc_maxlifetime 1440 1440
session.gc_probability 0 0
session.lazy_write On On
session.name phpListSession PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path /var/lib/php/sessions /var/lib/php/sessions
session.serialize_handler php php
session.sid_bits_per_character 5 5
session.sid_length 26 26
session.upload_progress.cleanup On On
session.upload_progress.enabled On On
session.upload_progress.freq 1% 1%
session.upload_progress.min_freq 1 1
session.upload_progress.prefix upload_progress_ upload_progress_
session.use_cookies 1 1
session.use_only_cookies 1 1
session.use_strict_mode 0 0
session.use_trans_sid 0 0

Going through your list and my php to cpare. Some differences:

session.gc_probability - mine set to 1
session.save_path - the local view has it set to the PHPlist ‘tmp’ folder. The master view is /var/lib/php/session

Everything else is identical.

The PHPlist is an installed application from the Godaddy Cpanel. pretty sure its the latest version - 3.6.10.
Not sure what else I can tell you about it. the system does work and we are sending out emails, at a slower rate at this stage so we don’t trigger any Godaddy limitations.

Its just this ability to use image management for the use of templates.

I will say though that I did have to move the folder in the server, because the Domain was redirected to a different folder on t he server. It may have mucked something up there, but from what I can see it seems to be pointing to the right places in t he settings menu.



What value is this? Can you find where the default value is changed, and remove it. Possibly in the config.php file.
My CPanel installation has the same value for local and master

Directive Local Value Master Value
session.save_path /var/cpanel/php/sessions/ea-php74 /var/cpanel/php/sessions/ea-php74

Otherwise I don’t really know what is causing the problem.

I think I have found the line of code. I remeber this line because it loaded with the install and when i removed it the PHPList stopped working.

@ini_set('upload_tmp_dir',dirname(dirname(__FILE__)).'/tmp'); if ( @ini_get('session.save_handler') === 'files' ) @ini_set('session.save_path',dirname(dirname(__FILE__)).'/tmp');

So I commented this line out and it set the session.save_path to the same location on both columns, but unfortunately it did not resolve the issue.

@jeddell You could try a small code change

in file admin/plugins/CKEditorPlugin/kcfinder/integration/phplist.php

try commenting out line 14. That should let the processing continue but if there is a session problem then I would expect something else then not work with the file browser

    die('Not logged in');

Just to confirm that the session is not correct you could add this after the session_start() line


which should display something in the file browser dialogue box.

Commenting out line 14 worked a treat. I also added the var_dump($Session); line and tried to open the image manager. you’re right again, it dumped a pile of code in the screen. It looks like a pile of text line. way too much to display her and in the middle of the dialogue showed the list of version updates. I suspect it may be the dashboard screen in code.

I’ll remove that line and crack on with my template designs.

I appreciate your help on this. Ill mark the post as a solution.

@jeddell Thanks, glad it is working but it wasn’t a session problem at all. Can you see whether these fields exist in $_SERVER, you can see that on the phpinfo page in the PHP Variables section


I found the first line in t he variables list. It has t he site’s IP address in the values fields.

The second line: $_SERVER['HTTP_X_FORWARDED_FOR']

is nowhere to be seen.

Is this a problem? If so, I’m open to suggestions.