Where to set timezone?

I am using PHPList 3.3.1 on a Plesk Linux VPS.

The timezone as reported by the “date” command on Linux command line is OK.
The timezone as reported by phpinfo is OK, after I I set it in the php.ini of the PHP handler via Plesk web admin.
The timezone as used by Horde webmail is OK, after I set it in Horde’s own php.ini. (at: /etc/psa-webmail/horde/horde/php.ini )

However I still see +0000 timezone being used in the mail body “phplist Message queue processing report”, i.e.:

The following events occured while processing the message queue:
[Fri 18 Aug 2017 09:02] [CL] Started
[Fri 18 Aug 2017 09:02] [CL] 3 messages sent in 0.69 seconds (15664 msgs/hr)

Where all the times above are in +0000 GMT timezone.

and also in the “Date:” mail headers, I see +0000 being used.

Weirdly enough, if I use “Send Test” under the content composing page, then the correct timezone is used.
Please see this screenshot side-by-side of text comparison. http://i.imgur.com/Rvm9FOl.png

Does this have something to do with phpmailer?

I use @Duncanc’s TimeZone plugin to match any server time to my timezone. Once installed, I just need to set the plugin settings to Europe/London and then the times used by phpList match.

Time Zone Plugin