Web pages not being received as HTML emails

I have two installs of phplist 3.2.1. The install that I am having an issue with has been working well for months. In fact, there are 6 email campaigns in the queue ready to send.

I am sending an email composed from a web page as html. When I receive the email, it is text. This is a new problem. I tried sending from my second install of phplist and it works fine. I also noted that if I attempt to create a simple html email using CKEditor, when I save the email, phplist will not save the message I just composed.

Something seems to be corrupt in my database. Any recommendations?

the first thing you’ll want to do is run a couple of the database utilities from the menus:
System, verify the db structure
System, rebuild db indexes.

If that doesn’t help, check that your plugins are up to date:

Config, manage plugins, and select ‘update’ for all of the plugins to make sure they are up to date.

Let us know if that solves it or not.

Thank you Dan for your response.

I performed the database utilities and plugin updates as you recommended. That did not resolve the issue.

If I try to compose an html message in my campaign, I type a few lines in the editor and select Save and continue editing. My edits are discarded rather than saved. Could something have happened with permissions?

I have also performed a fresh install on the same server and the new install does not have the problem.

1 Like

To get around this problem, I used a fresh install of phplist and a new database. Initially it worked. This morning, an HTML email that was queued up for my list went out. It was sent as plain text to 1000 recipients.

I tried a HTML test email. It showed up as plain text. I have no idea what could be wrong. My configuration is completely vanilla. I am beginning to believe that phplist may be to unstable to actually be used for anything important.

@MVandC Can you provide a step by step description of what you are doing that leads to a message being sent as plain text instead of html?
Without that it is difficult to try to repeat your problem and so diagnose what is happening.

Absolutely. And thanks for your response.

  1. From the List of Campaigns select “Start a new campaign”.
  2. Enter the subject “My subject”.
  3. Keep the default for the From line.
  4. Content: check the Compose message radio button and add some text and insert a graphic from the
    web. URL https://www.google.com/images/branding/googlelogo/2x/googlelogo_color_272x92dp.png.
  5. Keep the default footer.
  6. Select the Next button.
  7. On the next page, make sure Send as HTML is selected.
  8. From the Send test tab, I enter my email address and send the email to myself.

The email arrives as plain text.

1 Like

It is probably worth mentioning that I don’t have any plugins enabled other than CommonPlugin and CKEditorPlugin.

@MVandC In your config file what value do you have for this setting

# test emails
# if you send a test email, phplist will by default send you two emails, one in HTML format
# and the other in Text format. If you set this to 1, you can override this behaviour
# and only have a test email sent to you that matches the user record of the user that the
# test emails are sent to


If it is not present then the default value of 1 is used.
Please can you either amend or add the setting so that it is set to 0, and then send another test message. You should then receive two emails.

Also, can you confirm that on the user profile for your email address, it is set to receive HTML format emails

Can you look at the headers in the email that you received to confirm the content-type header. The headers should include something like this

Precedence: bulk
Bounces-To: xxx
List-Help: yyy
List-Unsubscribe: zzz
List-Subscribe: aaa
List-Owner: bbb
MIME-Version: 1.0
Content-Type: multipart/alternative;

The content-type in your email is probably text/plain

The problem was with the profile for my email address was set to 0 for Send subscriber HTML emails.

I did not change the setting. What could I have done to affect the profile? Do I need to check all of my subscriber profiles?

Thanks for your help resolving this issue for me.

On the Reconcile Subscribers page you can set all subscribers to receive HTML or to receive text format emails. But I don’t see how you could change that without remembering it.

If you want to send HTML format to all subscribers then use that command to ensure that everyone has the correct setting.

@duncanc is there any ways that subscribers will receive html format by default when they subscribed in? so no need to press reconcile button everytime we received a new subscriptions.