Web page sending not working


I am trying to send a campaign a second time. So, I used the same URL as the first time, and prepared the first step to grab the web page in question.

I get the error:
“Error fetching URL. Please verify that the URL entered is correct.”

But, the URL is the same exact one as when I sent the web page a month prior.

Why is my phplist not allowing a webpage that when I put inth browser, and sent via phplist 1 month ago, worked.

I use v 3.0.11 of phplist.

Thanks for any pointers


@smokinjo If you enable verbose in your config.php file then there should be more information in the event log page about the problem.

define ("VERBOSE",1)

Hello Duncan,

Thanks for the idea.

I have done this.

I try loading ¨PHPLIST again, and I get a white screen. It will not load onto screen.

When I remove the define verbose from the config.php, it works again.


Thanks for your assistance.


You need a ; at the end of the line for this to work, so:

define (“VERBOSE”,1);

@smokinjo Yes, that was a typo on my part.


I did notice it was missing after it errored, so I added it.

I am back in!

I tried sending the webpage, and I get that error again.

Where is the log file, and what am I looking for?


@smokinjo The event log page in phplist. I’m not sure what will be there but hopefully something about the error.

Thanks for the pointer for the location of the event log.

I have attached a screen capture fo the errors/events.

Hopefully they mean something.



@smokinjo Working from the bottom up, the first page (jpac.ca) genuinely doesn’t exist. The eco2 page does exist but phplist is getting a 0 return code, which doesn’t make much sense. The time between the first line for eco2 and the last line is 10s which suggests some sort of problem in connecting and then timing out.

Does this work with any other web page? If not then i suggest you raise the problem with your hosting company.


Each of the pages that I published are accessible via the web. I allows upload them and test them first.

In addition, I sent this same exact website across phplist 30 days ago, and it worked fine. Nothing has changed on my server

(the phplist and my websites are all on my own server)

You didn’t answer this question. If you enter say http://www.bbc.co.uk does phplist retrieve that page?

The jpac page does not exist as the url you have shown when I copy it and try to visit the url in my browser. Just like @DuncanC said earlier.


I tested a couple of webpages NOT ono our server. They work fine.

So, there is an issue with my server.

But, if you type the my webpage into a browser:

It works fine.

So, pages load in a browser, but NOT in phplist.

Is does phplist do something differently that my browser to load a page?


@smokinjo That page is being served using HTTP/2.0 which might not be supported by your php release. On my local phplist using php 5.6 I was able to retrieve that page.

Thanks for the diagnosis.
My PHP version is 5.4.45-0+deb7u5
My PHPLIst version is 3.011

According to the phplist website, php 5.4 is needed (for the current version anyway)

YOU mention my server is using HTTP/2.0. I might need to upgrade PHPLIList?

I have been thinking of installing the current version in another directory to the if it works.

If so, I will need to learn how to migrate my date.

Thanks for all help!

@smokinjo The page is now being served using HTTP/1.1 so either I misunderstood what was happening or something has changed. But on my server the page is retrieved by phplist. That is with php 7 and phplist 3.6.

It might be a problem with the server, the version of php, but I don’t really have any suggestion apart from upgrading php. You should also upgrade phplist to the latest version but I don’t think that is causing the problem.

I have not touched the server in any way, so I am not sure why you saw a change from http 1.1 and 2.0

I saw phpist 3.2.7, did you mean this?

I will try just installing the latest version of phplist and see what happens. It is an easy test, and not changes to the server are needed. I iwll let you know the results.


I ended up solving the issue with help from a friend of mine.

It turned out to be a DNS issue, which could not have been solved with any tinkering with phplist.

Thanks for all your help and suggestions.