Upgrade to 3.5.5

Tags: #<Tag:0x00007efff4c3b4f0>

Hi,

As you can see in the attached screenshot I have a message saying that my 3.5.4 version is up to date whereas a 3.5.5 version exists.
I tried the automatic updater but it does not work and displays the following message : Updater is loading
Error: The following files are either not expected and should be removed, or are missing but required and should be put back in place
error_log

Could you please share a simple detailed step by step solution for a non technical person like me ?