Update your preferences


I did not find anyplace in the >Settings where the text of the preferences page can be customized. I see transactional message customization options, but the language/instruction on the preferences page needs editing to be more clear for subscribers.

What file controls the wording here?

The confirmation screen after requesting the preferences page link is also confusing because it leaves the form field and previous text visible, below the ‘thank you’ bold text saying the system has emailed you a link to change your preferences.

Additionally, once you get to the preferences page, the page doesn’t jive. For example, the “* required fields are marked red” is false. There is nothing red on this page, just marked with asterisks. It would be helpful to add some instruction that to make updates on this page, the email address needs to be filled out (twice) regardless of whether the email address is being changed or not.

I’m at a loss to find where I can edit this text. Any help is appreciated.
Thank you.

@Nargauzius I think that most of the translatable text is in the lists/texts directory, one file for each language.
e.g. you can change the text for the required field

$strRequired            = 'required fields are marked red';

Thank you Duncan! I was able to find those and change the text. What was odd is that even though I changed the text in the usa.inc file that the subscription form uses. The one piece of text that did not change is the confirmation text on the /p=preferences page that indicates the data submission is being processed. “Success! …”
That I had to alter in the english-usa.inc file, which seems like a bug.