back to phpList.org

Unable to Update Email Address Attributes in Settings

Tags: #<Tag:0x00007f02f3a72ec8>

I am trying to update a number of email address fields in settings, but after I click save the value reverts back to the value prior to clicking save.

There is no error and I have been able to update another value that isn’t an email address.

Im guessing there is some kind of email address validation going on, but any support would be helpful.

I have enabled test mode and verbose logging, but not sure where to look for the log files.

@terryrogers This usually means that the new address that you entered already exists. There should be an error message near the top of the page but it disappears after a few seconds.

Ive double checked and I’m definitely not seeing any error message.

Are there any logs I can check?

@terryrogers I misunderstood which page you were changing.

On the Settings page the email addresses have validation controlled by the config setting EMAIL_ADDRESS_VALIDATION_LEVEL . Look in config_extended.php for an explanation then copy the setting to config.php with whichever level looks appropriate.

The email address I am entering is a valid email address, although is on a different domain.
With it being a valid email address, I don’t think the email validation level is the issue.

Any other ideas?

@terryrogers Are you saying that changing to any email address is being rejected? If not, then there must be something specific to the one that you are using.

Hi Duncan,

Thank you for coming back to me.

I took a quick screen recording so you can see exactly what is happening, please take a look here…

https://1drv.ms/v/s!AviWByF70_Mgg5ENXZB8GSRDM3Oamg?e=3jYvSM

Thank you

@terryrogers It is kind of what I suggested. If you had tried disabling email validation with EMAIL_ADDRESS_VALIDATION_LEVEL then it would probably have been accepted.

But it looks like the TLDs held in the database need to be updated. That should happen automatically but you can try to force an update by setting the frequency to be a small number of days. Add or update this to config.php

define('TLD_REFETCH_TIMEOUT', 1);

Ive updated my config.php setting EMAIL_ADDRESS_VALIDATION_LEVEL to 0 and also added the TLD REFETCH setting as well.

Neither appear to have made any difference, although I guess I need to wait for 24 hours to see if the TLD_REFETCH makes any difference.

@terryrogers Sorry but I don’t know.
Using EMAIL_ADDRESS_VALIDATION_LEVEL set to 0 should remove most validation. In my phplist I can update the field to the value that you are trying to use and I have EMAIL_ADDRESS_VALIDATION_LEVEL set to 3.

Hi Duncan,

Ive finally got it working, but I can’t say what the issue was as I completely wiped the site and started a fresh.

I now have an issue where it seems to not let me upload a logo though. Sighh…

1 Like