Unable get lock for processing

Having issues sending my latest newsletter. Send it out once per week, nearly 10,000 subscribers. About half way through this past weekend’s email the process queue gave the following error and continues to do so
"Unable get lock for processing"

Using version 3.2.4

In the past, this error seems to have been related to your server/host limits for email sending?
PhpList Mantis Report

I have had it ‘throttled’ for years now ensuring my limit of 400 emails per hour is not exceeded by only sending 300 per hour. I just upgraded to 3.2.4 before sending this email out and the issue arose after that. I have two accounts with newsletters and it only affected one account. I am confused!

Just a thought, have you checked that the throttle settings haven’t been over-written when you updated?

Sure did and also talked to my provider who stated our email wasn’t locked at all from the time we processed the queue. At a loss! I think I might export my list, back it up and try to reinstall to see what happens.

I’m having the same problem - did you ever figure it out? About half way through sending to about 6,000 subscribers it started giving that error message and won’t continue sending. I’m on 3.2.6, and my host says there are no sending limits in place.

It can also mean that there is already a processqueue process reporting that it is sending.
There is a table in the database that you can delete a record: that should fix it…

SELECT * FROM YOURDATABASE.phplist_sendprocess;

Will show you if any processes are alive. You can delete that record that indicates such, and you should be good to go.

This is what my provider found when this happened:
/usr/sbin/mysqld: Table ‘.phplist_sendprocess’ is marked as crashed and should be repaired

I repaired it and it worked after that. It happened a few times after as well and would have to go in and repair it.

I think it is the same thing danwaterloo mentions.

Thanks for the info! I’m a bit new to database management - could you let me know if I’m in the right place? Should I hit “Delete” here? Edit: Or just change “alive” to 0 or null?

2nd edit: I went ahead and changed “alive” to 0, and it worked - I just had to update the “stop sending after” date because it had passed, and it has now resumed sending. Thanks to both of you for your help!

1 Like

I think you need to go one level up where all the databases are listed in the right hand window. Check the box beside phplist_sendprocess scroll down and select repair table from the drop down action menu

Thanks, but I’m OK now - changing “alive” to 0 did the trick.

Hello the team, I’m experiencing the same issue. The difference is that when I turn the alive value to 0, the process initiates and sends but never ends. Any Idea to fix this ?
I run 3.6.12, and I never had problems with 3.6.10 and before.

I tried both with external smtp and with sendmail. I did not tried cron or remote. Thank you.

No this is incorrect, i had the same problem and could not resolve permanently resolve the problem. I asked Jesus (Son of God) for the solution.

To fix this error go to admin/lib.php edit the file to

while ($running_res[‘age’] && $count >= $max) { # a process is already running
// while ($count >= $max) { // don’t check age, as it may be 0