back to phpList.org

Trying to update from 2.10.19 to 3.2.0 - locked out of database

So, I was trying to update to 3.4.3, but was told I needed to go to 3.2.0 first.

So I downloaded 3.20, uploaded it, prepared the config.php file etc.

I then went to http://mydomain.com/public_html/lists/admin (example) and it asked me to log-in, which I did using my login name and password. It worked.

It showed me that I was in v3.2.0, and that the database needed to be upgraded. I decided I didn’t have time to finish it right that second so I would come back to it.

A few hours later, I came back to the page and it said it had timed out, and I needed to login again.

Now, entering the exact same login name and password FAILS. “incorrect password.”

Furthermore, I enter my email address in the forgotten password box, and it tells me “A password change token has been sent to the corresponding email address.” But I get no emails whatsoever. Checked junk, spam etc - no email is sent to me.

It’s as if the fact that I accessed the database once, but then didn’t finish the upgrade, has somehow reset the password or something. How can I get in here? Can I reset it somehow with phpmyadmin?

using phpmyadmin, you can go into the database and update the password for the admin user (usually record #1). you can type it in using plain text.

If your database has many records, the ‘conversion’ might take a while, just let it finish (minutes to hours )

Thank you! I did this and it worked - back in!

Indeed, somehow the password had been updated to a gigantic long string of random characters.

Also, update to 3.2.0 successful. Now on to 3.4.3.

1 Like

A long time back, the passwords were upgraded to MD5 which converts your password to the long string you now see. Nowadays, this has been changed slightly as previously you have to select MD5 in the dropdown box in the password fields, now you can simply type your password in and the next time you start phpList, your password is encoded.

Thank you for that explanation.

The problem I am now having is this:
I reset my password by typing it into phpMyAdmin.
I can then log-in to phplist.
Once I log out, and try to log-in, again it refuses my password.

I have to use phpMyAdmin to reset it again. And so on.

Any ideas how to fix this? I tried updating the admin password and it wants to send me an email with a ‘token’ yet I never receive the email (maybe a different problem). Thanks!

What version of php is on the system? it might need to be updated if it is less than 5.6. if you are on a hosted server, you can look on the control panel to find the info on the php.

or, once you login to phpList, if you have the “common plugin” installed, it will provide the info.
Or you can put a phpinfo.php file on your server, and view that via a web browser (search on google for instructions)

Sounds like the hashing system isn’t working for your passwords. As Dan says you should check your version of PHP and that the required PHP extensions are installed.

Thanks. As it turned out, once i got the phpMailer working again and was able to send myself a password reset message, I reset the password and now everything is fine again, I can login and out. I guess it just needed to be officially “reset”.