Trouble with Nginx configuration?

I have installed phpList on my Almalinux9 VPS running an Nginx webserver. I believe I installed phpList correctly. The ‘/lists’ directory is currently located inside ‘/usr/share/nginx/html’, which is where I have the rest of my website files.

After some trial and error, I suspect all of my configuration files are done correctly.

I am trying to setup phpList at the domain ‘php(dot)mydomain(dot)net’ – when I visit this domain, I get an error stating: “Database error 1146 while doing query Table ‘mydatabase.phplist_subscribepage’ doesn’t exist”.

When I visit ‘php(dot)mydomain(dot)net/lists/admin’, I get a 404 Not Found error.

When I visit ‘php(dot)mydomain(dot)net/admin/index.php?page=install’ (a suggestion from the robot), I am greeted with the phpList page with the following error at the top: “The pageroot in your config “/lists” does not match the current location “”. Check your config file.” – Then, if I attempt to click on ‘initialize database’, again I am met with a 404 Not Found error.

I am at the end of my rope here. I have no idea what else to try. I tried changing the $pageroot in config_extended.php to several different things (including an empty string), but nothing worked. I have tried a fresh install of phpList, but got the same results.

Does anyone have any other ideas??

Use the config.php file to make your changes, OR rename config_extended to config. That is the file phpList uses for it’s set up. The extended file is there as that has pretty much everything you need, config.php is basically a quick start up and has the minimum phpList needs.

Hi! Thanks for responding. The only thing from config_extended.php that seemed relevant was the $pageroot, which I also tried adding to config.php. I got the same results either way. In your opinion, is there something I’m missing?

That seems to be a subdomain. In that case $pageroot should be set to an empty string. You access the admin interface at

Ok! I got that to work. I added the $pageroot with the empty string back into config.php, and visited the /admin domain. It came up with no errors. However, when I click on ‘initialize database’, it logs me out and gives me this error: “You have been logged out, because the session token of your request was incorrect”.

Any suggestions?

@dave_childress Try closing the browser to clear the php session.

Tried that! No luck.