Test email not sent using phplist

this is my config.php settings

    	   $database_host = "localhost";
	   $database_name = "phplist_andi";
	   $database_user = "root";
           $database_password = '';
		define ("TEST",0);
		$bounce_protocol = 'pop';
		$bounce_mailbox_host = 'mail.mwancloud.com';
		$bounce_mailbox_user = 'demo-receive@magicpayments.com';
		$bounce_mailbox_password = '987hello';
		$bounce_mailbox_port = "110/pop3/notls";
	        $bounce_mailbox = '/var/mail/listbounces';
		$bounce_mailbox_purge = 1;
		$bounce_mailbox_purge_unprocessed = 1;
                $bounce_unsubscribe_threshold = 5; 

  when i click on send  test button it return   Sent test mail to: zargham.irtza@mwanmobile.com failed
  when i  debug for SMTP  in admin\sendemaillip.php
   $mail->SMTPDebug = 2; \\ debug smtp con
   i got an error  like

SMTP -> ERROR: MAIL not accepted from server: 551 This mail server requires authentication before sending mail from a locally hosted domain. Please reconfigure your mail client to authenticate before sending mail.


I see the bounce mailbox is setup, but what are your settings for the smtp (outgoing) server?
The smtp settings will most likely need:

  • hostname
  • port
  • username
  • user password.


     @danwaterloo thanks for quick response      
     im also trying with smtp phpmailer still getting same error 

                   define ("TEST",0);
		$phpmailer_smtpsecure = 'ssl';
		$phpmailer_smtpuser = 'demo-receive@magicpayments.com';
		$phpmailer_smtppassword = '987hello';
		$phpmailer_smtpport = '465';

If you are getting the same error about needing to authenticate, your smtp settings are not right.

Sometimes I use a client like Thunderbird or Outlook, and get that to work. Once that’s working, I can use the settings that work in T/O, and put them in the config.php file.

It seems easier to get the settings right in Thunderbird, and once I know what works, then put them into phpList.

Sorry after using stmp user name passowrd and host in config i got following errors , how can i avoid these?
SMTP -> ERROR: Failed to connect to server: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)
The following From address failed: demo-receive@magicpayments.com : Called Mail() without being connected

Did you get your email client to work successfully?

yes my email client is in working

Then you will need to get the settings from there, and plug them in the config.php file…

i’m not sure why you have the $phpmailier_xxxxx settings… remove them or comment them out.

here is a config that works for me, but with your values in it.

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
$phpmailer_smtpuser = 'demo-receive@magicpayments.com';
$phpmailer_smtppassword = '987hello';

@danwaterloo thanks for helping kindly guide me with this
Now emails are sent and received when i use send test
but didn’t receive real campaign emails when i try (click) send campaign and then processqueue what setting i have to do for this ?

you need to assign a list of email addresses to the campaign, and then on the last tab of creating a campaign, ‘submit to queue for processing’.

Then you can ‘system’, ‘process queue’.

i have followed all the steps to send campaign , still didn’t get any email … when i try send test email received successful , but when i try send campaign no email recived

You might want to consider some paid help via one of the people in this forum (me, duncanc, dragonrider, etc.)

Indeed, the info is here: https://www.phplist.org/paid-support/

Or use phpList.com.

thankyou very much you are so kind … @danwaterloo :stuck_out_tongue_winking_eye: :stuck_out_tongue_closed_eyes: