Struggling to get cron job timing corect

Good morning group. I have a phplist install that is supposed to send 500 emails every 15 minutes and it works well when i run it via a web browser. However when i run it via a cron job */15 * * * * php-cli /home/isotrain/public_html/phplist/admin/index.php -pprocessqueue -c/home/isotrain/public_html/phplist/config/config.php

i only get to send 1000 emails per hour becauseevery second one says
phpList version 3.2.4 © 2000-2016 phpList Ltd,
isotraining - Recently sent : 500
isotraining - Started [0.0161820000] (91)
isotraining - In the last 900 seconds more emails were sent (500) than is currently allowed per batch (500) [0.0003810000] (92)
isotraining - Script stage: 5 [0.0004000000] (93)
isotraining - Finished, Nothing to do [0.0003090000] (94)

So somehow i need to adjust it that it is able to send out 500 per 15 minutes but i am not sure how to fix this error. At the same time uping the sending emails per time to 1000 will not work. i need the emails to go out 500 per 15 minutes. Help please

It is not really possible to have the same batch settings for processing the queue with a cron job and through the browser. At the start of each batch phplist looks back to see how many emails have been sent in the past batch_period seconds. This ensures that the batch limit is not exceeded but also has the effect of reducing the sending rate.

You need to set the batch period to be a small number. Not sure whether 0s will actually work but, say, 5s will. You should also disable processing the queue through the browser because this change would lead to exceeding your batch limit.

thank you for your great feedback. how do i disable processing the queue through the browser?

@sabrahamse There is a setting in the config.php file, manually process bounces. I recommend that you set that to 0 so the command does not appear in the admin menu.

I meant manually process queue!