[SOLVED] Segment plugin cannot be enabled

Just updated to 3.3.5, Segment plugin has been disabled in the process. On the plugin page I try to enable it, but after the page refreshes it is still disabled. Tried updating and even manually installing the plugin, but it keeps being disabled.

Anyone any ideas?

@Ronald2404 It’s an error in one of the changes, made by me.
I have raised the problem on Mantis https://mantis.phplist.org/view.php?id=19453
but the quickest solution for you is to replace the file admin/pluginlib.php by unzipping the attached file
pluginlib.php.zip (2.4 KB)

You can see the actual changes to pluginlib.php here https://github.com/phpList/phplist3/pull/411/files


@duncanc Great, that worked.
Thank you for your swift reaction!

Greetings Ronald

1 Like

Hi Duncanc,
After replacing the pluginlib.php file (as described above), I can’t get to my plugins at all!
When I go to Config → Plugins, I get the message, “plugins → Sorry, not implemented yet”.

I have deleted the “CampaignsPlugin” (ftp), but this also did not help.
How can I manage my plugins again? (They still seem to work)

Thanks for an answer,

@Rovanov This post and problem is five years old so is not relevant any longer. You don’t need to change any files, so just revert any changes you have made.

Thanks duncanc,
I did this because the CampaignsPlugin could not be activated.

I have put everything back but the problem remains. And the error message remains when I go to Config → Plugins, I get the message, “plugins → Sorry, not implemented yet”.

So I can’t see the plugins anymore either

Looks like you have deleted the file admin/plugins.php

Yes, that was the problem.
Can’t remember that I deleted it and it wasn’t in the trash either.

Thanks again Duncanc!