[SOLVED] Problems started in 331 and now 333

While using 331 Over night, the “ContentAreas” plugin not showing the edit areas tab.

Seemed like a good time to update to 333 and did so.
Backed up db, transfered info to new config extended file and renamed config…
Changed the admin user name to four or more in length to login.
updated db and…

Campaigns go to the queue and are processed but none are being sent. The campaign stays in the active tab and never finishes sending…
Can’t update an admin’s password because no password token can be sent

I have now installed a fresh new installation of 333.
Have not added subscribers, etc from old db. The campaign goes to the queue and sends but “fails” sending to only one subscriber
still cannot get it to send (yes TEST = 0)
When going to the program on website it starts with a [no such account] notice that disappears, and then I login

Sounds to me like a problem in config file (have checked all info against new extended file and don’t see colons’s semi-colons’s or brackets’s missing.

Been using phplist from early versions of 2 and have never had a problem with upgrades of any kind.
PHP 7.2 installed
PHP 7.1 installed
PHP 5.6.36 (default)
MySQL 5.7.22

This is usually because the template does not contain any content area attributes.

You can enable VERBOSE in the config file to get more detail in the event log on what is happening when phplist is processing the queue.

tr data-hideable=“rsvp-dinner”
td data-edit=“amount”
div data-edit=“location”
these are three of the seven edit areas in my template that have been working great since you created the plugin.

When I enabled VERBOSE I got the following on a one person campaign…
select id from pl_message where status not in (“draft”, “sent”, “prepared”, “suspended”) and embargo

I don’t think it is your plugin, there are several other things I am experiencing with the 333 ver.

  1. I cannot add a new admin because I cannot set a new password or update a current one.
    it appears no tokens can be sent from the system.
  2. when sending a campaign to one or two people it works great; however, when sending to just 500, the queue never finishes. I am manually starting the queue (removed the cron).
    I have two systems - first with 630 subscribers and the second with 2,368 subscribers, each with 15-22 subscriber lists.

I’m not even sure it is sending to everyone when placed in the queue. I had to disable all of the smtp info to get it to send a test message and I am still getting the problems above.

I have now removed all plugins to see if that might be the problem… it wasn’t, no change.

My config file has been working until this problem in 333… any chance it might be in that file?

The password token problem has cleared at this point (11:14 AM America/Denver time)…
I went into the 331 version I am using on another server, added a new admin with the password I wanted.
Copied that pw from it’s db and changed it with the password in the ver 333 db. Now all tokens seem to be working.

The other issues are the same as noted originally

I disconnected all of the smtp info that was working in 331 and went back to PHP mail()… I am now able to send “test” and emails now in vr 333.

Working with the server tech to find a solution to the smtp problem. Here is what I was using
d e f i n e (‘PHPMAILERHOST’, ‘mail.s483.sureserver.com’);
$ phpmailer_ smtpuser = ‘postmaster@xyz.org’;
$ phpmailer_ smtppassword = ‘12345678’;
d e f i n e (‘PHPMAILERPORT’, 587);
d e f i n e (“PHPMAILER_SECURE”,‘auto’);

change in phpmailer class.phpmailer.php
p u b l i c $ AuthType = ‘Plain’;

The version of PHPMailer is 5.2.22 the same in 331 and 333 so I can’t see where the problem with smtp lies.

But still no edit Content is showing on the tab area

Confirm that the plugin is enabled on the Manage Plugins page.
On the Format tab ensure that you have chosen a template that has content areas.
If the template is not valid html (such as mismatched quotes or brackets) then the Edit Areas tab won’t be displayed. So check the Event log for any errors reported there. For example

Checked your reply this morning, opened the program went to a test email using the template with edits and the tab was showing (no changes of any kind). Send a couple of test messages and was able to edit or hide without problems. Downloaded the template, checked for errors and found none. Uploaded same template and would not work. Checked multiple things for 30-40 minutes, turned the pc off and rebooted. Things are working with the template once again.
I have this in the log, and the content edit tab is showing and the template is working…
168665 31 August 2018 06:53:25 DOMDocument::loadHTML(): htmlParseEntityRef: no name in Entity, line: 66

Can you tell me what it is referring to?

@johntrot There is something wrong on line 66, possibly relating to use of &.
Remember, if you want a literal & character then it needs to be entered as &

Thanks, your insite worked.

1 Like