[SOLVED] Page Not Found / WordPress issue?


I’ve been using phplist for many years and I’m trying to install it on a new site. But I’m having a problem. I have WordPress installed in the root of public_html. I have created a new folder ‘email-sender’ where I uploaded all of the phplist files. But when I try to access http://www.leakyourmusic.com/email-sender/ or http://www.leakyourmusic.com/email-sender/admin/, I just get a Page not found error as if they were part of the WordPress installation.

Anyone experienced this before or know how to fix it? Thanks!

Your error page appears because you have a 404 error trap set in your Wordpress .htaccess file and any errors found will cause your custom 404 page to appear. You could try temporarily disabling this and see if you get a clearer error message.

In the meantime, have you changed the $pageroot value in your config/config.php file to point to your email-sender folder?
Also, are you 100% sure that this is the correct name for your phpList folder/directory?

The error I get after disabling the WordPress 404 error trap is a: 500 Internal Server Error.

I have added the following to my config file:

$pageroot = ‘/email-sender’;
$adminpages = ‘/email-sender/admin’;

But I still get the same error. And I am 100% sure that the folder name is correct.

With version 3 you don’t need to use $adminpages any longer. Are you sure that the folder name is correct and that it’s not in another folder off the root?

Yep, I’m sure.

I just set up a new installation of phplist (this time through my cPanel’s Softaculous software installer) in the folder /email-list but I get the same error:


It’s located in public_html/email-list/

Would you be willing to let me have a look? If so, please send me a PM with your server log in details and I’ll see if there is anything obvious.

I just sent you a PM. Thank you!

Hi, thanks for trusting me, I’ve had a look and cannot see any logical reason why this shouldn’t work.
I’ve even tried installing a fresh copy via Sofilicous using the defaults, and it doesn’t work either. I think you need to ask your host why as there must be some setting they have that prevents your accessing any phpList folder.

I created a test folder with a simple hello world display and that worked fine. Ask your host if they are blocking something.

I just talked to my host and apparently it was caused by mysql not being compiled with easyapache. They added the mysql feature and recompiled apache on my server and now it’s working.

That is great news, thanks for getting back to us with the cause, and solution to your problem.