back to phpList.org

[SOLVED] Not seeing views or unique views in 3.3.3

statistics
333
Tags: #<Tag:0x00007f92622df158> #<Tag:0x00007f92622def78>

#1

I have several installations of PHPList, some for many years. Recently (last year or so) email reports are saying 0 views and 0 unique views in the campaign reports, also in the statistics views. Two installations are of v3.3.3, the other is 3.3.1(?)… All have [USERTRACK] in the footers of the messages, all messages are html, and most are actually opened. The config files are set up with define(‘ALWAYS_ADD_USERTRACK’,1) or have the line commented out (since v3.x defaults to tracking users). One of these sites has about 50,000 users, so the problem is not at the recipients end. The total messages sent is correctly reported. All have proper settings for the domain name in the config file.

I’ve tried a few experiments here, but still getting 0 views, e.g. turning Google analytics settings off. I verified in the sent emails there is the proper image (i.e. ut.php?u=…)

One site is http://www.banjartamu.org/plist. Any ideas on how to fix this?
Thanks


#2

Have you checked that the image is actually loadable? E.g. Copied the url of the image and opened it in a browser?


#3

Good idea. Thanks, that seems to be the problem! But I don’t understand why – the url has an “=” inserted into part of the domain name, so the image doesn’t work. I checked General settings and the domain name is fine there. Similarly with the other domain, tho the “=” comes after the domain name (just before the /). Now I see that the = occurs at the end of lines that somehow are getting into the footer (not there when I look at the footer in PHPList). So the whole footer is somehow forced into 72(?) character lines with an = as the last char on the line. What’s causing that and how to fix this??

Looking at the source in my email client (Thunderbird) I’m not sure what formatting it’s putting in and what came from PHPlist. I do note that a text version of the email is in the first part of the multipart source followed by the html version, and the footer at the very bottom with the fixed line length.

Let me know what I can do to diagnose/fix this. Thanks again.


#4

Well actually that does NOT seem to be the problem – other links that show the “=” sign in them, e.g the Powered by PHPList one, work fine. So that = is only showing up when I look at the source of the email in my email client (I also tried looking at this in Gmail on the web, and I see the same thing as in Thunderbird).

Actually looking closer at the source in my email client, it’s not clear (to me, at least) how this is supposed to work as the ut.php part is only referenced in the alt part of the spacer image ?!?! Here’s what that part of the source looks like (displayed by an email client):

`<p class=3D"poweredby" style=3D"text-align:center"><a href=3D"https://www.p=
hplist.com/poweredby?utm_source=3Dpl3.3.3&amp;utm_medium=3Dpoweredhostedimg=
&amp;utm_campaign=3DphpList" title=3D"visit the phpList website" ><img src=
=3D"cid:c00003465866755ef08e5dddd7aab15f" title=3D"powered by phpList versi=
on 3.3.3, &copy; phpList ltd" alt=3D"powered by phpList 3.3.3, &copy; phpLi=
st ltd" border=3D"0" /></a></p><img src=3D"https://s3.amazonaws.com/msv5/im=
ages/spacer.gif" width=3D"1" height=3D"1" alt=3D"Web Bug from http://www.xy=
zxyzxyzx.org/plist/ut.php?u=3Dc08665072db326e7c5a3afbf97e35083&m=3D437" /><=
/body></html>`

(I changed the domain name).

If I go to (using the real domain name)
http://www.xyzxyzxyzx.org/plist/ut.php?u=3Dc08665072db326e7c5a3afbf97e35083&m=3D437
it appears to work – a black screen appears. So how can I tell if this web bug is working and the problem is perhaps elsewhere? Since PHPList reports 0 views, it’s not, but my question still is why??? And how to fix?

BTW here is the footer as set up in PHPList:


This message was sent to [EMAIL] by [FROMEMAIL] – you can update your email address here

To forward this message, please do not use the forward button of your email application, because this message was made specifically for you only. Instead use the forward page in our newsletter system.
To change your email address or other details, visit your personal preferences page
Or you can opt-out completely from all future mailings.

And if you somehow got this email and wish to be on the email list, you need to contact me (Dave) at the original sending email address, , sending me who referred you, your name and email.

[USERTRACK]

At the bottom of my mesage the Powered by PHPList image appears ok in the emails.

Anyhow hoping someone has suggestions/ideas on how to resolve this. I can pm details of all, as there’s nothing very private in any of this.


#5

It looks like some security software is detecing the image tracker and replacing it with an ordinary image. I’d be surprised though it every subscriber was affected by this, unless they are all on the same domain or belong to the same organisation.


#6

Duncan, Thanks, but no, they’re a cross section of the population totally. (Note that the xyzxyzxyzx.org is a fictitious domain name). Could it be something on my server doing that? I would think the web bug would just be a plain and not in the alt tag – is that the way PHPList normally does it?

Anyhow I will pm you the complete email source, and anything else you might think helpful, and I can give you access to the admin area. Whatever will help me get past this.

Thanks,
Dave


#7

Here’s my latest views report
BTStats


#8

@BaliDave Your server appears to be running MailScanner.

X-ScubaDivers-MailScanner-Information: Please contact the ISP for more information

The default configuration for that is to disarm web bugs, which is what is happening in your test email.
https://www.mailscanner.info/MailScanner.conf.index.html#Allow%20WebBugs
The content of the src attribute is copied to an alt attribute, and replaced by a real image. You can get your system admin to change the configuration to allow web bugs to see whether that changes anything. MailScanner should be looking at incoming email though so I’m not sure why all emails should be affected.


#9

Duncan, YES, that was it. I turned off disarming web bugs in MailScanner (my host provider had set that up) and now I get views and unique views. So apparently MailScanner was scanning outgoing messages too, tho I could find no mention of that in the config file for that.

Anyhow MANY thanks for this. Interesting that no one else has run into this before (AFAIK) too.
Thanks again!


#10

One more problem with the web bug: In another site that is a secure site, i.e. all pages are https:, the web bug gets garbled in the email sent out with a prepended http://. So it looks like

<img src=3D"http://https://www.xyzxyzxya.org/elist/ut.php?u=3D15e0a6090025d3cc78ce32a9a9806790&amp;m=3D609" width=3D"1" height=3D"1" border=3D"0" alt=3D"" />

in the email source. With the http:// prepended to the https:// in the URL, the image isn’t resolved and thus the email does not get tracked, so no views recorded. How can I force PHPList to drop the http:// in the web bug? I do not see any config options for this.


#11

@BaliDave I guess that the website address field on the Settings page is wrong.


#12

I have https:// in the website address, but maybe that’s not supposed to be there (?). I’ll drop that and test; will report back.


#13

@BaliDave image


#14

Duh. Yep, that did it.


#15

@BaliDave Please mark this resolved if that’s the case