[SOLVED] Installation Problem with 3.3.1

I just install the 3.3.1 version of phpList in a clean directory. Initially, I customized the config/config.php file for my existing phpList database and pointed my browser at the new installation.

I end up with at HTTP 500 Server Internal Server Error message.

I followed a suggestion that I found here on the forum to revert back to a clean config.php file in hopes of getting the “can’t access the database / you need to configure phpList” message.

Even after reverting back to a clean config.php file I still end up with a HTTP 500 Server error.

Every time I attempt to access a 3.3.1 phpList page, the following message is logged in the server’s error log:

[error] [client] Failed loading /usr/php/56/usr/lib64/php/modules/ZendGuardLoader.so: /usr/php/56/usr/lib64/php/modules/ZendGuardLoader.so: undefined symbol: zend_execute_ex

My Bluehost based Linux server is running PHP 5.6

The URL to the 3.3.1 installation is www.scws-al-anon.org/lists_3.3.1/

The URL to the existing 2.10.19 installation is www.scws-al-anon.org/lists/

Any and all suggestions are welcome

I can install version 3.2.7 with no issues, so it appears the problem I’m having is related to the 3.3.x versions.

From what I’ve read here in the forum, the mcrypt module or access to /dev/urandom is required starting with 3.3.0

I used phpinfo() to check my server configuration and the mcrypt module is installed.

Fun, Fun, Fun (this actually is the best fun I’ve had in a while…)

@bpopelar You should raise the problem with the hosting company as ZendGuardLoader has nothing directly to do with phplist.

and the http 500 error is an apache error, which would indicate that the issue is with apache, not phplist.
I’d look around on your apache modules that are loading, and the different versions of what is loading. it could be a version issue with something (php, etc.)

I started off by contacting my hosting company, which was as fruitful as you might imagine. They blamed everything on the application and suggested I contact the developer. It is fairly obvious that this in not a common problem with the users of phpList, otherwise I would have found many posts here on the forum. There is something unique about the configuration of PHP and / or Apache on my server that is leading to the ZendGuardLoader issue when the Apache server attempts to execute the phpList pages.

I’m going to spend some time this weekend installing the versions between 3.2.7, which does work, and the current version and try and determine what version introduces the issue on my server. Once I know that, I’m hope the developer community can help me understand what new PHP features / modules were introduced. Hopefully from that information, I’ll be able to identify what PHP configuration parameters need to be change…

So I see that my idea of walking through the various released versions of phpList between version 3.2.7 and 3.3.1 is a non effort…the only version between the two was 3.3.0 and it was removed from distribution due to “issues discovered”

So what major PHP language features or modules were introduced in version 3.3.0 / 3.3.1?

The error looks to be an incorrectly installed or configured ZendGuardLoader php module. Possibly that module is not being loaded for your current installation of phplist but for some reason is being loaded for the new one.

Do you have a php.ini or htaccess file that references it, or maybe a way of configuring php in the control panel? phplist doesn’t use encoded files, which is what ZendGuardLoader seems to deal with, so there is no need for the module to be enabled.

I agree it looks like an incorrectly installed of configured ZendGuardLoader php module.

I do have a php.ini file that references it. The one provided by the hosting company (Bluehost) does not look correct given what I’ve read on the Zend website. They have the ZendGuardLoader.so extension included, but they do not have the Zend version of the opcache.so extension include (which the Zend website clearly states that the standard version must be replaced by their version).

I spent quite some time over the weekend playing with the php.ini configuration trying to find a combination of settings that would allow the 3.3…1 version of phpList to load / execute. I could not find a configuration that would work.

Even though the php.ini file includes the various Zend extensions, phpInfo() does not list the extensions in the output. Furthermore, phpInfo() reports the php version as 5.2.17 instead of 5.6.x. So it looks like the Apache server is running php version 5.2.x, but the php.ini file is set up for 5.6.x (and as far as the cpanel configuration is concerned, it thinks the hosting account is configured for php 5.6.x)

It’s clear from looking at the common Apache log on my shared server that my website is not the only one having issues with ZendGuard or one of the competing products (ioncube / ixed) that are also installed on the server.

So I made one last call to Bluehost technical support. I now had enough information to convince them (or at least a competent IT rep) that the php configuration on my server was hosed.

They manually configured my server for PHP version 5.6 and everything magically started to work.

The phpList version 3.3.1 installation now generates the “Cannot connect to database, access denied…” message. So now all I have to do is properly configure phpList to access my database and all should be well.

Thanks for the help


Hello bpopelar

I am a long time PHPList user and poster, first time posting on the new board.

I too am with bluehost. I asked them to upgrade/update my PHP version on my server and they updated it to 5.6.29 (for those that need to check the method I used was http://www.mississauga4sale.com/info.php hopefully this will work on your server)

Even with this version I have attempted many times to upload PHPList 3.3.1 to my server and when I attempt to login I still receive the dreaded error “HTTP ERROR 500”

I’ve uploaded a testing version of V3.3.1 to this folder on my site: mississauga4sale.com/lists3.3.1-not-workingMay-25-2017/admin/

Do you have another other suggestions or ideas that I could try that may allow me to update my version of PHPList?

I am still only able to use V3.0.12 I was able to load version 3.2.4 and login to this version and update the database but when I attempted to use my cron job to send the emails it won’t fire. I tried 10’s of different variations of my cron line but could never get it to work so I downgraded back to V3.0.12

Version 3.0.12 is my functioning version and is located at: /lists/admin/

Version 3.2.4 is the non working version located at: /lists 3.2.4 on Dec 9 2015 cron won’t fire/admin/

Version 3.3.1 that I want to get working is located at: http://www.mississauga4sale.com/lists3.3.1-not-workingMay-25-2017/admin/

Any help or advice would be greatly appreciated.

Thank you,

PS: Nice to be back to the forum! :smile:
PSS: the system will only allow me to post 2 links because I’m a new user! lol

HI Mark,

I see by your phpInfo() output that your webserver is using PHP 5.6.x Does this agree with the version report on your Bluehost cPanel page?

For me, the phpList version 3.3.1 did not start working until the output from the phpinfo() command reported the PHP version as 5.6.x, but it seams you already have that issue handled.

Even when I finally got Bluehost IT to fix the PHP version, it was still clear that all was not right on my webserver; there were still many error message being generated to the central PHP log that were clearly related PHP installation issues. My website is on a shared server and there were a slew to PHP module related error message being generated by other websites hosted on the same server, as well as a few from mine.

Have you tried looking at the central PHP server log to see what errors are being reported when you access the phpList version 3.3.1 page? It might be useful information to pass on to Bluehost IT support. this was a bit of a trick on my server as there was another website that got a lot of hits, so it was difficult to figure out which PHP errors were related to my attempts to access my website…with an HTTP ERROR 500 the central log did not identify the URI and source of the query that causes the error.


Hi Ben,

I will try your suggestion of looking at the error messages. As you say, there are other errors due to the shared server, but I’ll see what I can figure out and report back once I’ve had the time to do this.

Thank you,

Here’s how I would recommend you upgrade your system:

  1. back up your database (just in case)
  2. download the phpList 3.3.1 to your desktop.
  • unzip the full release
  • descend into the …/public_html directory
  • zip the ‘lists’ directory and all subdirectories. name it something like lists3.3.1.zip This is the file you will upload to your installation
  1. rename your existing ‘lists’ directory to another name, such as ‘lists.3.0.12’ (if you want to ‘restore’ your install, just rename the folder back to ‘lists’
  2. upload your ‘lists3.3.1.zip’ file to your public_html directory on your website.
  3. unziip that file (it will create the lists directory and all the subdirectories.

At this point, you should be able to browse to your installation on your website, but it won’t be able to connect to the database.

  1. rename the lists/config/config.php file to config.php.orig
  2. copy your config.php file from your old installation, and paste it into the lists/config/ directory.
    Now your old settings are installed in the new installation.

Everything should work as usual.

Hi Dan

Thanks for your detailed instructions.
I tried exactly what you told me, zipped the lists directory and all subdirectories, uploaded the zip file, renamed existing folder, unzipped the file, it did create a list folder with all other folders and files inside it, uploaded old config.php file and voila… nothing, same HTTP ERROR 500 again… now I’m really stumped.

Any other suggestions?

I had to revert it back to old version for now…

I’m willing to try anything…

Hi Ben,
I tried to login several times and received the HTTP ERROR 500 and then imediately went to my error logs and could not find any reference to phplist errors or a 500 error or any recent errors related to PHPlist. There were some errors but none were related to PHPlist

There are some errors from a while ago that reference PHPlist, such as:

[24-May-2017 09:15:28 America/Denver] PHP Warning: PHP Startup: uploadprogress: Unable to initialize module
Module compiled with module API=20138709709709I added numbers not sure if sensitive or not 124244768 PHP compiled with module API=2009709709I added numbers not sure if sensitive or not 1034343430525
These options need to match
in Unknown on line 0

but there were no errors showing in any part of June 2017 for lists folder

I had this error, but again, it’s not this month but last month:

[26-May-2017 08:51:45 America/Denver] PHP Notice: Undefined variable: page in /home6/mississa/public_html/lists 3.3.1 not working may 25 2017/admin/locale/en/pagetitles.php on line 3

Does any of this help?


JUNE 6th

Hi Dan,

  1. I’ve tried renaming the url for PHPlist to just lists when I attempt to login and I’ve just changed the name to (as you suggest underscores) as this:
    and this still gives the HTTP ERROR 500

  2. If I use the search:


it shows the PHP Core Version as 5.6.29

I’ve had to edit my post as the system will not allow me to upload more than 3 replies because I am a new user! is there any way that a moderator can fix this for me so I can continue to reply to this post rather than edit this post?


and Ben, for your reply to the HTTP Error 500 I will send a ticket to bluehost and see if that mis-match in numbers is the culprit

Hi Mark,

Typically a HTTP Error 500 happens so early in the execution of the web server that it cannot identify the URL of the page being served or the IP address of referrer; that’s what makes them so hard to track down.

HTTP Error 500 is almost always a serious mis-configuration of the web server (i.e., Apache) and it’s associated plugins. It is damn near impossible to generate a HTTP Error 500 just by code up a page incorrectly in PHP or HTML. PHP will generate a error_log files (in your user directory where the PHP files / pages are served from) as long as the PHP interpreter (the Zend engine) can load the various modules which are configured.

The error messages you have listed are interesting. In the first one, the API version numbers are not compatible between Apache server and the a PHP module. If this is repeatable, this is the exactly what you need to report to Bluehost so they can correct the configuration. BTW - I see API mis-match errors in the PHP shared server log on my server all the time (not the exact one you have above); its one of the reasons that I know my server is still not configured correctly.

The second error message is the more typical PHP error that occurs when a web page is mis-coded by the programmer. I have not seen this error and since my admin backend is configured for English, I assume I would have seen this error had it existed in the distribution. I’m assuming it was just an glich in the upload process.

Unfortunately, I can’t tell you much more. Keep looking a the server logs and see if you can detect a pattern on accesses to your website. That’s the kind of info your are going to need to focus Bluehost IT support on the issue that is driving your webserver in to the ground.


The 500 error is an apache error…

  1. By the way, I would NOT uses spaces in a url… use an underscore ‘_’ where you want to have a space.
  2. make sure that you have php V5.6 or greater installed. (check by using an info.php file) Google if you don’t know how to do that.