[SOLVED] Error "Sorry, sending the message to request your confirmation failed" but not when logged as the admin

Hi! I’m setting up phplist to move my newsletter to this system.

I encountered a problem where the mails from the campaigns are sent without problems but when a user tries to subscribe gets this error:
" Sorry, sending the message to request your confirmation failed, please click “Reload” to try again. If it still does not work, please contact the administrator."

The mail shown in the above error is the one from the settings “Person in charge of this system”.

But when I use the same public page while being logged in as the admin, the error doesn’t show up and the confirmation mail is sent successfully.

In the log page I get this message:
Error sending email to binws@protonmail.com The following From address failed: carlo@playerdue.com : MAIL FROM command failed,EThAmX4CbrIRlEThAm8Zpa authentication failed ,550,5.1.0SMTP server error: MAIL FROM command failed Detail: EThAmX4CbrIRlEThAm8Zpa authentication failed SMTP code: 550 Additional SMTP info: 5.1.0SMTP server error: MAIL FROM command failed Detail: EThAmX4CbrIRlEThAm8Zpa authentication failed SMTP code: 550 Additional SMTP info: 5.1.0

These are the options for the smtp in my config.php file:

define('PHPMAILERHOST', 'smtps.aruba.it');
$phpmailer_smtpuser = 'newsletter@playerdue.com';
$phpmailer_smtppassword = 'password';
define('PHPMAILERPORT',465);
define('PHPMAILER_SECURE','ssl');

@Playerdue It is a problem in the latest release of phplist. See this earlier topic Confirmation emails fail - #4 by laserpen

Thank you for the reply! I added the code on config .php but the behavior is the same, with a different error.

Error sending email to binws@protonmail.com SMTP connect() failed.

When I’m logged as the admin the confirmation mail is sent without problems from the subscription page, but when I try on the same page not logged it says again “Sorry, sending the message to request your confirmation failed, etc…”

@Playerdue Can you check that the config.php entry has single quotes. If you simply copied and pasted then it might have the wrong quote character

should use ' not ’

I’m ashamed to say I changed the quotes around PHPMAILERSUBSCRIBEHOST but not on the second part, now it’s working!

Thank you very much! Sorry for the noob mistake! :stuck_out_tongue:

hi Guys!
i am still getting same message. already working on it 4 hours. no result. please check.
first i tried

define(‘PHPMAILERHOST’, ‘mail.smtp2go.com’);
define(‘PHPMAILERPORT’,2525);
define(‘PHPMAILER_SECURE’,true);
// SMTP Authentication
$phpmailer_smtpuser = ‘yyyyyyyy’;
$phpmailer_smtppassword = ‘xxxxxxxxx’;

then i tried:
define(‘PHPMAILERSUBSCRIBEHOST’,‘’);
define(‘PHPMAILERHOST’, ‘mail.smtp2go.com’);
define(‘PHPMAILERPORT’,2525);
define(‘PHPMAILER_SECURE’,true);
// SMTP Authentication
$phpmailer_smtpuser = ‘yyyyyyyy’;
$phpmailer_smtppassword = ‘xxxxxxxxx’;

then tried:

define(‘PHPMAILERSUBSCRIBEHOST’,‘’);
define(‘PHPMAILERHOST’, ‘here-also-same-server’);
define(‘PHPMAILERPORT’,465);
define(‘PHPMAILER_SECURE’,true);
// SMTP Authentication
$phpmailer_smtpuser = ‘yyyyyyyy’;
$phpmailer_smtppassword = ‘xxxxxxxxx’;
//define(‘PHPMAILERPORT’,‘465’);
define(‘PHPMAILER_SECURE’,‘ssl’);

and some other variants.
no works. please help

this is difficult at best to figure out just using the config.php file.

Here’s what I do… using thunderbird (an email client), I setup the email box, and thunderbird tries all of the settings, and usually picks the settings that works. then I look at what thunderbird figured out, and adjust the config.php settings to match the thunderbird settings. it’s a little easier than what you’re doing