back to phpList.org

SOLVED: Ckeditor toolbar keeps disappearing

plugins
Tags: #<Tag:0x00007fe3e136bf10>

#1

I have 3 php installations on one server, each serving a different domains.

phplist 3.3.3

Suddenly all the ckeditors in each of them are gone - well, the plugin is still on with the green tick mark in the plugins configuration page and the common plugins states that it is current. Here is some information that may help someone help me troubleshoot this:

CKEditorPlugin
Details
Name CKEditor plugin
Description Provides the CKEditor for editing messages and templates.
version 2.1.3+20160603Update status Plugin must be updated manually
More information Documentation Page Configure CKEditor Settings

Name Common Plugin Developer bramley
Description Provides support classes required by some other plugins.
version3.9.0+20180905 Update status Plugin is up-to-date
Installed 2018-09-07
installation Urlhttps://github.com/bramley/phplist-plugin-common/archive/master.zip
More information Documentation Page

Fckeditor works, not ckeditor.

All directories have proper permissions and ownership.
Any suggestions?


#2

As a side note I see that Duncan recommends in a former posters similar issue to check the ". . . On the Settings page what is the setting for “Path to ckeditor”?

But on the setting page there is only the input for " Path to CKeditor custom configuration file" which is not “path to ckeditor”.

In any event, inputing that there, doesn’t bring back my toolbar for ckeditor.

I thought all paths for ckedtior are in the plugins directory and config.php file.


#3

On another note when I attempt to get php.info from the phplist link on the front end, I receive the following errors in the logs file (note this is for getting pph.info NOT when I attempt to access the ckeditor editor).

Forbidden
You don’t have permission to access /lists/admin/index.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
“GET /lists/admin/?page=phpinfo&pi=CommonPlugin&tk=e0f5sd1fca949sssscccec2d5d8b57fbc HTTP/1.1” 404 - “https://www.domain.com/lists/admin/?page=session&pi=CommonPlugin&tk=e0f5c1fca9fdfsdfec2d5d8b57fbc” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64) Gecko Firefox/62.0”

tailing apache logs for when accessing a campaign trying to use the ckeditor shows no errors or 404’s in the apache logs.


#4

And now I see on a totally different server, different ip the same thing has happened - my ckeditor toolbar has disappeared.

Is something running amock out there in phplist world?


#5

I now have done a completely fresh install using all standard procedures on a standard cpanel server separate from all others. phplist works but there is absolutely NO ckeditor to be found. It is activated as you can see from the screenshot, but it’s not there.

This is 3.3.4


#6

You won’t believe this, but it came down to DNS. My DNS provider could not connect to:

`//cdn.ckeditor.com/4.5.7/full/ckeditor.js

Amazing!


#7

Thanks for letting us know the issue, glad to read it is now fixed. :wink:


#8

Can ckeditor.js be in the distribution so users don’t have to connect to ckeditor.com to download code each time they use phphlist? Or are there legal ramifications about the use of it?


#9

You can install a local copy of ckeditor, as explained in the plugin documentation https://resources.phplist.com/plugin/ckeditor


#10

I did install the plugin as instructed. It works only when it can make a connection to the url specified .js file.


#11

I’m referring to ckeditor itself, not the phplist plugin. You can install a local copy of ckeditor if you do not want to access the remotely hosted ckeditor.


#12

this is kinda whacky… but i just ran into the same situation.

ckeditor worked 100% fine on my end. i was trying to troubleshoot for 2 hours… i finally did a remote connect to my client.

i found that their DNS was blocking https://cdn.ckeditor.com/4.5.7/full/ckeditor.js.

i updated their windows DNS settings to use Google’s DNS, 8.8.8.8 & 8.8.4.4… and the problem was immediately resolved.

i’m happy that i ran into this thread! made for quick resolution :slight_smile: