[SOLVED] Amazon SES plugin, newbee problem

Hello, I’m unskilled and new to phplist, with limited budget im trying to hosting it on my paid shared hosting server. I’m using it in combination with Amazon ses plugin, and i read thought documentation, i got out of sandbox mode in Ireland server and changed settings for SES endpoint to apigateway.eu-west-1.amazonaws.com (made sure it’s not pointing to STMP server), entered access key ID, and secret key too.
Now when I to send simple test campaign to my own email address I can not, I contacted server admin and first he said he whitelisted my acc and later asked ‘if I can whitelist it on their side?’. I’m not aware of such a option on amazon side, since i have right keys I guess that is a form of sufficient identification.

Now I get this error in case when I send one simple campaign to my own email adress;
event log:
408 12 October 2018 03:49:22 MailSender http code: 0, result: , curl error: Failed to connect to apigateway.eu-west-1.amazonaws.com port 80: Connection timed out

I installed phplist with help of cpanel > softaculous. phplist version

PHP Version 5.6.38

© phpList ltd. - v3.3.4

@MSSS You don’t appear to have the right endpoint, see https://docs.aws.amazon.com/ses/latest/DeveloperGuide/regions.html#region-endpoints

Oh such a rookie mistake; OK i corrected it (email.eu-west-1.amazonaws.com) but again I get error:
12 October 2018 21:46:35
MailSender http code: 0, result: , curl error: Failed to connect to email.eu-west-1.amazonaws.com port 80: Connection refused

Any ideas why?
Thanks duncanc

You probably need to be using https, not http, in the endpoint.


Your the man! :slight_smile:
I just added https:// to the end, there was not even http before, just got my first test campaign.
Really happy, thanks again.

I have the same issue and when I try to add the https:// to the endpoint I get a 403 http error (not allowed on server) - any clues?

OK - I did a direct update on the DB to add the https:// and all worked after that - but perhaps someone could look at the issue with the 403 error in updating the settings?



This might be caused by anti-malware on your web server rejecting POST requests containing certain strings. That happens to me when for example submitting what looks like an html page from the phplist settings page.

Do you have a Wordpress site that uses Wordfence or have the apache mod_security module enabled?

yes - the mod_security module is enabled

One small other issue is that I am getting both txt and HTML emails when I do my tests - any ideas?


sorted - searched better in the forum - only happens in the test setup and I have updated config.php to resolve – sorry about that - love your plugin !!!