phpList.org

Shows blank page for dashboard when logged in

Hello,
My home page, login page, subscribe page and unsubscribe page; all works fine but when I am trying to Login at: https://example.com/admin using my Username & Password then it shows Blank Page.
Hop someone can help me to fix this issue.
Regards,

This is often down to an error in a file that you have edited such as config.php where you have missed a semi-colon (:wink: off the end of a line.

But why it only affects your admin page, that I’m not sure.

Hello Dragonrider,
My previous hosting is on shared hosting where I faced some problems.
So, I have changed my hosting service and now I am on VPS on another hosting provider and this problem happened as I have converted my domain (example.com) from Child Domain to Primary Domain.
Please tell me exactly in which Line, semi-colon missed; so that I can correct it.
Regards,

Hello Dragonrider,
I have checked my config.php file but there were no one semi-colon missed as well for the satisfaction; I have also changed current config.php file with the config.php backup file but the situation is same.
There is still a blank page.
Please help me to fix this issue.

Regards,

Hello Friends,
I have follows the direction given by @Dragonrider but there were no one semi-colon missed and there is still a blank page.
Please help me to fix this issue.
Regards,

Try this
Login to your cPanel account.

In the Databases section, click on PhpMyAdmin.

Next, select the database you want to work with.

All tables in the database will be displayed on the right.

Click Check All at the bottom to select all tables. Next, in “With selected”, select Repair table.

When the repair completes, try accessing your admin panel to see if this resolves the issue. If yes, great! But if wp-admin is still not working, then it’s time to debug.

Hello @sarahk99 , @Dragonrider
Here is the error log, please take a look to point-out the actual problem & to fix it. I have already reviewed it but I am not sure where is the problem.
2020-10-31 20:24:43.842566 [INFO] Rewrite directive: bypassed.
2020-10-31 20:24:43.842571 [INFO] Invalid rewrite directive: RemoveHandler .cgi .pl .py .pyc .pyo .phtml .php .php3 .php4 .php5 .php6 .pcgi .pcgi3 .pcgi4 .pcgi5 .pchi6 .inc
2020-10-31 20:24:43.842584 [INFO] Invalid rewrite directive: RemoveType .cgi .pl .py .pyc .pyo .phtml .php .php3 .php4 .php5 .php6 .pcgi .pcgi3 .pcgi4 .pcgi5 .pchi6 .inc
2020-10-31 20:24:43.842589 [INFO] Invalid rewrite directive: SetHandler None
2020-10-31 20:24:43.842593 [INFO] Invalid rewrite directive: SetHandler default-handler
2020-10-31 20:24:43.842597 [INFO] Invalid rewrite directive: AddType text/plain .html
2020-10-31 20:24:43.842601 [INFO] Invalid rewrite directive: AddType text/plain .htm
2020-10-31 20:24:43.842607 [INFO] RewriteFile [/home/example.com/public_html/images/.htaccess] parsed, return 0.
2020-10-31 20:25:28.017479 [INFO] Invalid rewrite directive: <FilesMatch “.(php|inc)$”>
2020-10-31 20:25:28.017498 [INFO] Rewrite directive: <IfModule !mod_authz_core.c> bypassed.
2020-10-31 20:25:28.017502 [INFO] Invalid rewrite directive: Order allow,deny
2020-10-31 20:25:28.017505 [INFO] Invalid rewrite directive: Deny from all
2020-10-31 20:25:28.017508 [INFO] Invalid rewrite directive: Satisfy All
2020-10-31 20:25:28.017511 [INFO] Rewrite directive: bypassed.
2020-10-31 20:25:28.017519 [INFO] Rewrite directive: bypassed.
2020-10-31 20:25:28.017522 [INFO] Invalid rewrite directive: Require all denied
2020-10-31 20:25:28.017525 [INFO] Rewrite directive: bypassed.
2020-10-31 20:25:28.017528 [INFO] Invalid rewrite directive:
2020-10-31 20:25:28.017531 [INFO] Invalid rewrite directive: <FilesMatch “(index.php|connector.php|upload.php)$”>
2020-10-31 20:25:28.017535 [INFO] Rewrite directive: <IfModule !mod_authz_core.c> bypassed.
2020-10-31 20:25:28.017537 [INFO] Invalid rewrite directive: Order allow,deny
2020-10-31 20:25:28.017540 [INFO] Invalid rewrite directive: Allow from all
2020-10-31 20:25:28.017543 [INFO] Invalid rewrite directive: Satisfy All
2020-10-31 20:25:28.017546 [INFO] Rewrite directive: bypassed.
2020-10-31 20:25:28.017549 [INFO] Rewrite directive: bypassed.
2020-10-31 20:25:28.017552 [INFO] Invalid rewrite directive: Require all granted
2020-10-31 20:25:28.017555 [INFO] Rewrite directive: bypassed.
2020-10-31 20:25:28.017558 [INFO] Invalid rewrite directive:
2020-10-31 20:25:28.017562 [INFO] RewriteFile [/home/example.com/public_html/admin/.htaccess] parsed, return 0.
2020-10-31 20:27:55.967426 [INFO] Invalid rewrite directive: <FilesMatch “.(php|inc)$”>
2020-10-31 20:27:55.967453 [INFO] Rewrite directive: <IfModule !mod_authz_core.c> bypassed.
2020-10-31 20:27:55.967457 [INFO] Invalid rewrite directive: Order allow,deny
2020-10-31 20:27:55.967460 [INFO] Invalid rewrite directive: Deny from all
2020-10-31 20:27:55.967463 [INFO] Invalid rewrite directive: Satisfy All
2020-10-31 20:27:55.967466 [INFO] Rewrite directive: bypassed.
2020-10-31 20:27:55.967469 [INFO] Rewrite directive: bypassed.
2020-10-31 20:27:55.967472 [INFO] Invalid rewrite directive: Require all denied
2020-10-31 20:27:55.967475 [INFO] Rewrite directive: bypassed.
2020-10-31 20:27:55.967478 [INFO] Invalid rewrite directive:
2020-10-31 20:27:55.967481 [INFO] Invalid rewrite directive: <FilesMatch “(index.php|connector.php|upload.php)$”>
2020-10-31 20:27:55.967487 [INFO] Rewrite directive: <IfModule !mod_authz_core.c> bypassed.
2020-10-31 20:27:55.967490 [INFO] Invalid rewrite directive: Order allow,deny
2020-10-31 20:27:55.967493 [INFO] Invalid rewrite directive: Allow from all
2020-10-31 20:27:55.967496 [INFO] Invalid rewrite directive: Satisfy All
2020-10-31 20:27:55.967498 [INFO] Rewrite directive: bypassed.
2020-10-31 20:27:55.967501 [INFO] Rewrite directive: bypassed.
2020-10-31 20:27:55.967504 [INFO] Invalid rewrite directive: Require all granted
2020-10-31 20:27:55.967507 [INFO] Rewrite directive: bypassed.
2020-10-31 20:27:55.967510 [INFO] Invalid rewrite directive:
2020-10-31 20:27:55.967514 [INFO] RewriteFile [/home/example.com/public_html/admin/.htaccess] parsed, return 0.

Regards,

Hello @sarahk99,
It’s still shows blank page.

Regards,

Hello,
How can I debug wp-admin to fix this issue?

Regards,

Hello,
I am still struggling with this issue and I can’t find any solution for this problem and need help from the developers team members as well other users whose knows well that how can fix it.
Please help me.
Regards,

@Peteh2 View the html source of the page using CTRL-U, there might be an indication of an error towards the bottom of the html.

Hi,

I’m working on french transtaltion of phplist.
I encountered that problem several times! :stuck_out_tongue:
The reason was always because an update of a config file or a php file like:
language.inc, config.php, home.php, defaultFrontendTexts.php, connect.php…

Go back to the original version of the file and try again.

Jojo

@duncanc
Sorry for late reply. Here is the html source of the Admin Dashboard:
indent preformatted text by 4 spaces

phpList :: phpList :: Dashboard
Toggle navigation phpList, email newsletter manager, logo

Recently Visited

    العربية Bulgarian Català Česky danske Deutsch ελληνικά english español Español (Argentina) فارسی suomi française Galician עברית Croatian magyar Icelandic italiano 日本語 Lithuanian Latvian Norwegian Nederlands Vlaams polski Portuguese Portuguès (Brazil) Romanian русский Slovak Slovenian Albanian Srpski svenska Turkish Việt 简体中文 Traditional Chinese

    Dashboard

    Hide

    phpList will work without Javascript, but it will be easier to use if you switch it on.

    All is that, But “WHAT I CAN SEE, IS A BLANK PAGE” only.
    Regards,

    @Peteh2 You could try reinstalling the phplist code, not the database, but save and restore the config.php file.
    Also confirm that the phplist requirements are met https://resources.phplist.com/system/start

    The apache log that you showed previously looks a mess. Possibly ask your hosting company why valid .htaccess lines are being rejected.

    You can try enabling error reporting. In file admin/init.php line 9 is

    error_reporting(0);
    

    change the 0 to -1 to enable all errors

    error_reporting(-1);

    @duncanc Thanks for the right way to fix this error. Now I feel some relax that I am being able to see my Dashboard after a long time.
    How To Do It:

    1. Keep safe config.php file and database only.
    2. I have deleted all of the website files, folders etc. to make it clean.
    3. I have uploaded the list folder of latest phpList ver. 3.6.0
    4. Delete default config.php file and upload the backup config.php
    5. Visit example.com/admin to login using login credentials.
    6. Magic…Dashboard shown!!!
      Finally this problem is going to fixed without knowing the actual “Bug”.
      Can anyone pin-point the actual point of error?

    Thanks for help and support.

    1 Like

    Scratching my head on this. I solved it in the past with previous versions, but it seems I just can’t this time. It’s a fresh install of 3.6.1. downloaded directly on the server via wget and unzipped there too.

    It shows the admin login page, but after sending the form it’s a blank page (with some HTML code on the background). I tried to use my own config.php backup first, but then I tried with the vanilla config.php, to no avail. If I don’t edit that config file, the expected message of error connecting to the database appears, but whenever I enter the server data (host, database, user, password), it just goes blank.

    I’m on Ubuntu 20.4, PHP 8.0.2 and Apache 2.4.41

    PHP has all these modules enabled:

    [PHP Modules]
    bz2
    calendar
    Core
    ctype
    curl
    date
    dom
    exif
    FFI
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    imagick
    imap
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    sockets
    sodium
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    xml
    xmlreader
    xmlwriter
    xsl
    Zend OPcache
    zip
    zlib

    [Zend Modules]
    Zend OPcache

    Thanks a lot in advance!

    More tests:

    • Tried switching from executing php8 as PHP-FPM to as an Apache module, just in case it was some esoteric permissions issue. No luck, blank page after login.
    • Also tried fresh-installing previous versions (3.6.0, 3.5.7), but they didn’t even show the login page or public subscription pages.

    I think it’s probably an issue with the PHP version? Let me know how can I debug this, I’m not experienced on that. Thanks a lot in advance.

    @allvoxman Have you tried enabling error reporting? That is explained in an earlier response.
    If the page is still blank then view the underlying html.

    Error reporting enabled, no errors reported & still blank page. This is the HTML that’s produced:

    @allvoxman Do you have a timezone set? Try adding this to the end of the config.php file to see whether it makes a difference

    date_default_timezone_set('America/Los_Angeles');

    Also, just to rule out any plugin can you rename the lists/admin/plugins directory and create a new empty directory in its place.