Random subscribers added en masse. How do I stop?

Sometime in the last couple weeks, I started getting 20x the number of subscribers–most of which bounce and none of which open/click emails.

Here’s what I’ve tried to rectify the issue:

*I’ve restored a back-up of the server from two weeks before the problem began

*I’ve updated PHPlist to the current version

*I’ve changed the password on the database

*I’ve removed the opt-in form on the site

*I’ve changed all Subscribe Pages in PHPlist to inactive

But, I’m still being flooded with fake/random new subs.

What else should I try to keep these subs from being added?


@cmcasemart If you want to stop all subscriptions then consider handling this in the .htaccess file with a mod rewrite rule to reject any subscription URL.

Otherwise, you could add a captcha field to the subscribe page. There are a few captcha plugins, see plugins:start [phpList Resources]

I’ve disabled the subscription page via .htaccess per your suggestion

If anyone else needs that code, here’s what I added:

RewriteEngine On

RewriteCond %{QUERY_STRING} ^p=subscribe$ [NC]

RewriteRule ^ - [F]

Now, if you visit the subscription page here it won’t work:


But, you can still add subscribers by using a POST to this URL.

How can I actually block folks from subscribing?

@cmcasemart Not sure what you mean but you probably want to change the condition because it can also include a subscribe page id

RewriteCond %{QUERY_STRING} p=subscribe [NC]