Queue not sending. No errors

phpList v3.6.8

I created a campaign, set the embargo time to one hour before the current system time, and placed it in the queue. After clicking the Process Queue button, the wheel spins for a few seconds, then queue status box says “All done”. No emails were sent and there were no error messages. I click the “Resume processing” button, and the same thing happens.

If I try to send a test message from the campaign’s Finish tab, it goes to a blank screen (no images or text of any kind) and never sends the test.

I’ve been using this installation of phpList for two years. I recently upgraded to 3.6.8, but I have sent at least two campaigns since then.

I enabled verbose logging, and this is all I got back:

15310 2022-09-14 07:53:38 Fetching https://download.phplist.org/version.json?version=3.6.8 success
Page: eventlog
15309 2022-09-14 07:53:38 fetched https://download.phplist.org/version.json?version=3.6.8 status 200
Page: eventlog
15308 2022-09-14 07:53:38 https://download.phplist.org/version.json?version=3.6.8 fetching with curl
Page: eventlog
15307 2022-09-14 07:53:26 sending of this campaign will stop, if it is still going in 182 days 11 hours 6 mins 34 seconds
Page: pageaction
15306 2022-09-14 07:53:26 Report of processing will be sent by email
Page: pageaction
15305 2022-09-14 07:53:26 Please leave this window open. phpList will process your queue until all messages have been sent. This may take a while
Page: pageaction
15304 2022-09-14 07:53:26 One campaign to process.
Page: pageaction
15303 2022-09-14 07:53:26 Processing has started,

@koerper70 Has the version of php that is being used changed? Try to find a php error log. Sometimes that is in the lists/admin directory, or might be part of the web server log.

I recently upgraded to 3.6.8, but I have sent at least two campaigns since then.

I included the phplist log entries in my original post.

I haven’t checked the server logs, though. I’ll see if I can find those.

I watched the server error logs while retrying the queue. There were no new entries in the logs, so there’s no help there.

@koerper70 Try enabling error reporting by adding this to the file admin/processqueue.php



I added “error_reporting(-1);” to the processqueue.php file. When that didn’t add anything to the logs, I tried “error_reporting(1);”. That didn’t do anything either.

I also set “error_reporting(1);” in init.php. Again, nothing new in the logs.

I also tried this code from from Troubleshooting Techni... | phpList manual :

$GLOBALS[‘show_dev_errors’] = true;
ini_set(‘display_errors’, 1);
ini_set(‘display_startup_errors’, 1);
$developer_email = ‘your@email-address.com’;
$GLOBALS[‘show_dev_errors’] = true;

The first line broke the whole site. The rest didn’t do anything with the first line removed.

@koerper70 “-1” means all errors, so that was intended.
With that enabled you should get php errors reported in a php error log which is usually separate to the web server log.

Are you able to run processqueue from a command line or cron job as that might any errors more visible?

Does the blank page happen each time that you try to send a test email? Try viewing the html source of the blank page as there might be something hidden.

1 Like

When I try to view the page source after attempting to send a test email, I get this error:

# Confirm Form Resubmission

This webpage requires data that you entered earlier in order to be properly displayed. You can send this data again, but by doing so you will repeat any action this page previously performed.

* Press the reload button to resubmit the data needed to load the page.


I’ve been looking at the “Log of Events” in the PHPList System menu. Are there more logs that aren’t available from the GUI?

I’ve never used the command line, so I suspect there’s a significant learning curve there.

@koerper70 I am referring to a php error log, not phplist. As I said, often there is an error log file created in the lists/admin directory. For example in my server’s file system

I have not seen before that message about form submission when viewing the page source.

Unfortunately, I don’t see that file there.


Got it! My config.php was missing one setting:

define(‘PHPMAILERHOST’, ‘mymailserver.com’);

I don’t know why I didn’t need that in the past, but once I enabled this setting and defined my smtp server, everything started it working again.