Queue is stuck after sending two mails


To keep below the limit of sending mails from our hosting provider I have set:

I use the webinterface to proces the queue.

But when I sent a mail as test to a subscriber list with four e-mail adresses the queue seems to be stuck after sending two mails.
In the log it says Ready with this stage (“Klaar met deze fase” in Dutch)
When I stop and resume the queue it continues.
Got to stop and resume again for finishing the queue.

All mails are delivered fine and are not marked as spam by the hosting provider.

Is there a way to see why I have to stop/resume the queue?

The hosting provider has set max execution time en max input time to 120seconds, but that did not help.
Are there other recommended settings we could try?

I’m not sure if I can use the cron on our shared environment.

Kind regards

On this page:

it says:
“When run from a webpage, phpList, by default, will only run the queue processing for one minute. It will try to send as many mails as possible in that time. Then you will need to run it again.”

Could this be why I have this problem?

@Peter-sdl You could try not having a throttle value but set batch size and batch period instead - maybe a size of 2 and period of 60 just to see whether it is more reliable.

The way that this should work is that phplist processes for only one minute elapsed time, including any throttle delay, then exits. On the browser page, some javascript makes a further request to run processqueue, so this requires the browser to be kept open on the the processqueue page and for javascript to work reliably.

You could also try setting this in config.php to tell phplist to create a delay in javascript in the browser instead of in the php code

define('JSLEEPMETHOD', 1);

Also set this to get more information on the event log page

define('VERBOSE', 1);

Thanks @duncanc
Setting a size of 2 and period of 60 seems to work ok.
Also set define('VERBOSE', 1); which may also be helpfull.

I’ll do some more testing coming weekend and let you know the results.
But for now it’s definitely a step forward.

As promised I come back after testing this weekend.
Result: works like a charm.
Thanks @ duncanc