Quarter million entries in event log

not sure how to stop this?
we have about 250,000 entries in our log file over the course of a couple days.
nearly all of them read;
**Less than batch size were sent, so reloading imminently**
we are on a shared host … we have throttling set for 150/hr.
after the 150 go out the above message is recorded several times a second.
it can be stopped by closing the phplist session (browser tab) or by suspending the queue.

I’m guess this is not intended function, right?

also, as a secondary issue … if I filter the log display … it would be a bit more intuitive to have the DELETE function operate on the displayed events only. especially in the above case!!

thanks in advance for your insight.


edit v3.3.1

How often is your cron running?

Using phpList on a shared host is not ideal, throttling to 150/hr is a good idea, so good work on that.
the “less than a batch” message indicates that the number of emails sent in the last batch period was less than what is allowed (by the settings in the config.php file), so the system tries sending again.

I would delete all of the log entries, run your campaign for 15 minutes, and then pause it. then you browse more easily through the log messages to see what’s going on.