back to phpList.org

Problems sending mail, You are only allowed to send 5 messages per 80 seconds


#1

Hello All,

I have had some issues sending mail using PHPList 3.3.2.
There are 500 subscribers to the newsletter and i seem to be hitting the max 5 emails per domain in any 80 seconds.

I have added the below to the config file to prevent this from occurring, however it s not having the desired effect.

define(‘MAX_PROCESS_MESSAGE’, 10);

define(‘MAILQUEUE_BATCH_SIZE’, 0);

define(‘MAILQUEUE_BATCH_PERIOD’, 3600);

define(‘MAILQUEUE_THROTTLE’, 1);

define(‘MAILQUEUE_AUTOTHROTTLE’, 0);

define(‘USE_DOMAIN_THROTTLE’, 1);
define(‘DOMAIN_BATCH_SIZE’, 3);
define(‘DOMAIN_BATCH_PERIOD’, 100);

define(‘DOMAIN_AUTO_THROTTLE’, 1);

define(‘MAX_PROCESSQUEUE_TIME’, 0);

If anyone has any ideas where i am going wrong i would love to hear from you.

Andrew.


#2

define(‘MAX_PROCESS_MESSAGE’, 10); send up to 10 campaigns simultaneously
define(‘MAILQUEUE_BATCH_SIZE’, 0); send as many as you can
define(‘MAILQUEUE_BATCH_PERIOD’, 3600); every hour
define(‘MAILQUEUE_THROTTLE’, 1); wait 1 second between messages (which would throttle to about 3600/hr)
define(‘MAILQUEUE_AUTOTHROTTLE’, 0); don’t set the auto throttle

define(‘USE_DOMAIN_THROTTLE’, 1); Limit the speed to sending to a given domain
define(‘DOMAIN_BATCH_SIZE’, 3); 3 emails
define(‘DOMAIN_BATCH_PERIOD’, 100); per 100 seconds
define(‘DOMAIN_AUTO_THROTTLE’, 1); let the system figure out the delays between messages

define(‘MAX_PROCESSQUEUE_TIME’, 0); let the system take as long as it needs to send a batch queue

Note that yahoo is complaining you are sending too fast. Yahoo, Hotmail, outlook and live all use the same mail servers, so they would be considered the same domain, but phpList might consider them separate domains. I remember that there was a configuration setting to tell phpList that… not sure where it is.

Since you have 500 subscribers, and the limiting factor on the receiving end is 5 every 80 seconds, why not send at 4 every 90 seconds, or , so you are below the limit, no matter what the destination. It won’t take too much longer to send… 3600 sec/hr / 90 sec = 40 batches/hr . 40 batchs/hr x 4/batch = 160 /hr
spreading them out evenly over the hour : 3600 secs/hr / 160 emails/hr = 22.5 sec delay between emails
like this:

define(‘MAX_PROCESS_MESSAGE’, 10); send up to 10 campaigns simultaneously
define(‘MAILQUEUE_BATCH_SIZE’, 160); send 160 emails
define(‘MAILQUEUE_BATCH_PERIOD’, 3600); every hour
define(‘MAILQUEUE_THROTTLE’, 23); wait 23 seconds between messages
define(‘MAILQUEUE_AUTOTHROTTLE’, 0); don’t set the auto throttle

define(‘USE_DOMAIN_THROTTLE’, 0); turn off domain throttling
define(‘DOMAIN_BATCH_SIZE’, 3); 3 emails
define(‘DOMAIN_BATCH_PERIOD’, 100); per 100 seconds
define(‘DOMAIN_AUTO_THROTTLE’, 1); let the system figure out the delays between messages

define(‘MAX_PROCESSQUEUE_TIME’, 0); let the system take as long as it needs to send a batch queue

set your cron job to run every 5 mintues, if you have 500 email addresses, it will take 500/160 = ~ 3 hours and 10 minutes to send, and you won’t run into these ‘sending too fast’ rejections.


#3

Hi Dan,
Thank you for your response.

Do we need to use a cron job?
We haven’t had to set this up in the past, but i expect i can do this via cpanel.

Thank you.
Andrew.


#4

Hi Dan,

I am having an issue after making these changes.
I was expecting the changes would send the emails at around 160 per hour.
What i am seeing is 6 emails every 5 minutes being sent, approx 72 per hour.

The good part is all the emails have been sent, however its taking around 7 hours to complete.

I am going to test further to try and speed it up a little. 3 hours is fine, 7 hours is abit too long.

If you have any recommendations then please let me know, otherwise thank you for your help, your recommendations solved the 5 messages per 80 seconds errors.

Cheers,
Andrew.