back to phpList.org

Please help in configuration file

Sorry if i ask for help, but i’m not able setup PhpList.
as first i installed it via Softocoulous under Cpanel on my host (Mochahost)

database is working… but sending mail no.

I try al kind of setting in config/config.php line 102
but i was not able set it correctly

my sever has SMTP with and without SSL
SMTP without port 25, 2525 on Server1
SMTP ssl is 465 on Server2

Please someone can help me ?
i try all kind of combination server/port/SSL on config.php line 102

Tnks in advice

Hi @Disaster.net the latest line of “my” config.php file is 84 (it’s related to the hash method for password) then :wink: it seems you 've added some unknown settings here, isn’t ?
Which version 're you using?

try
define(“PHPMAILERHOST”,’ smtp1.mydomain.com:465’);
define(“PHPMAILER_SECURE”,‘ssl’);

Substituting your smtp domain in the first line above.

Sorry for my late…
my version of PHPList is 3.5.0.
and my config … is different…

?=================
/ Message envelope. This is the email that system messages come from
// it is useful to make this one where you can process the bounces on
// you will probably get a X-Authentication-Warning in your message
// when using this with sendmail
// NOTE: this is very different from the From: line in a message
// to use this feature, uncomment the following line, and change the email address
// to some existing account on your system
// requires PHP version > “4.0.5” and “4.3.1+” without safe_mode
// $message_envelope = ‘listbounces@yourdomain’;

// Handling bounces. Check README.bounces for more info
// This can be ‘pop’ or ‘mbox’
$bounce_protocol = ‘pop’;

// set this to 0, if you set up a cron to download bounces regularly by using the
// commandline option. If this is 0, users cannot run the page from the web
// frontend. Read README.commandline to find out how to set it up on the
// commandline
define(‘MANUALLY_PROCESS_BOUNCES’, 1);

// when the protocol is pop, specify these three
$bounce_mailbox_host = ‘MY_HOST’;
$bounce_mailbox_user = ‘MY_EMAIL’;
$bounce_mailbox_password = 'MY_PWD
’;

// the “port” is the remote port of the connection to retrieve the emails
// the default should be fine but if it doesn’t work, you can try the second
// one. To do that, add a # before the first line and take off the one before the
// second line
$bounce_mailbox_port = ‘2525/pop3’;
//$bounce_mailbox_port = “110/pop3”;

// it’s getting more common to have secure connections, in which case you probably want to use
//$bounce_mailbox_port = “465/pop3/ssl/novalidate-cert”;

there are not this “define” values …