PHPList was sending the campaigns until one day it was not able to send more campaigns

Hi Phplist discuss community

I have phplist v3.6.12 installed.
It was working fine until nov 8th. On nov 9th after a campaign was submitted (Active campaigns) it never starts sending the emails.
What could be happening? Where else can I see what is happening?
Nothing appears in the Event Log page
Please your help would be appreciated


1 Like

Hey Mauricio,
we have the same problem. We were start sending a campaign at nov 8th wich worked fine according to the processing report E-Mail but since nov 9th we dont get any report anymore and the process of the campaign list stopped. We are even not able to send test Mails since that date.

Hope the issue will resolved soon.

Kind regards Jan

@msrodrigp You can get more detailed output in the event log by enabling verbose, add or amend this line in config.php

define('VERBOSE', 1);

then look at the Event Log page after trying to process the queue.

I have the same problem, PHPlist only sends 400 of 2000 emails, reinstalled on a different domain, unfortunately that doesn’t work either

After enabling verbose adding “define(‘VERBOSE’, 1);” in the config.php file
In order not to wait for the cron, I tried to trigger the camapings manualy issuing on the linux command line:
su phplistuser -c “/usr/local/bin/phplist2 -pprocessqueue > /dev/null”
Then I clicked on System → Log of Events and nothing new since nov 8th.
The last message on nov 8th is:
Found them: 13621 to process

So I tried the same command wihout redirecting to /dev/null
su phplistuser -c “/usr/local/bin/phplist2 -pprocessqueue”

An got the following:
phpList - phpList version 3.6.12 (c) 2000-2023 phpList Ltd,
phpList - A process for this page is already running and it was still alive 0 seconds ago
phpList - Running commandline, quitting. We’ll find out what to do in the next run.

Then I tried the same command on other working phplist
su phplistuser -c “/usr/local/bin/phplist3 -pprocessqueue”

This time, I got the following:
phpList - phpList version 3.6.14 (c) 2000-2023 phpList Ltd,
phpList - Started [0.3511760000] (285)
phpList - Script stage: 6 [0.0018280000] (291)
phpList - Finished, Nothing to do [0.0006760000] (294)
phpList - Finished, All done [0.0798980000] (301)

For me, it seems that some process is stuck in my phplist2

Any ideas?

Best regards

Delete all rows from the sendprocess table, then try again. But ensure that the cron job is not going to be running at the same time.

Also, it is best to output to a file so that if anything goes go wrong you can see the output of the most recent run.

Hi Duncanc

After deleting the record of phplist_sendprocess the phplist started sending the campaing inmediately.

Thank you and best regards

Although the phplist is working now, why did this happen?

@msrodrigp phplist inserts a row into the sendprocess table at the start of queue processing, then deletes that at the end. This is to stop another run of processqueue concurrently. The second run will see the row in the table and exit.

If a row was left in the table then phplist must have terminated abnormally. The row should eventually get deleted by a further run of processqueue after 10 minutes.