PHPList created huge MariaDB table phplist_i18n after auto-updater paused

Tags: #<Tag:0x00007f891804d140>

Hello!
Must the phplist_i18n table be 43,899 rows before I even start to configure the config.php file?

I am new to this, so please bear with me…

I am using:
hosting company with Plesk Obsidian 18.0.35
phplist was offered as a “click and install” app option. But they do not offer the latest Phplist. v3.2._

To install, I had to change my php down to v5.4.

Install worked. I try to update through automatic-updater. Advised me a Licence.txt file and an index.html were an issue and could not complete update. After searching here, I moved the licence file out of /lists and I created a dummy index.html in /lists. This allowed the updater to proceed. It seemed to hang on the “uploading” part for quite some time. As in over an hour. I went back to my plesk dashboard and changed my php setting to 7.3.28 (what is was before I downgraded to 5.4). I went back to the suspended browser window and refreshed it. It installed!

BUT, it said my DB needed to be upgraded (MariaDB, using PHPMyAdmin), the utf8. It gave a dropdown menu and I selected “general.”

Now, when I go to look at this massive table, it says:
44,097 KB InnoDB utf8_general_mysl500_ci 8.5mib 0b for “overhead”

Questions: Did I set the utf8 at the wrong setting? Can I change it without doing the install for PHPList from scratch? Or can I just delete all these rows in the table to reduce the database size?

Thank you in advance

@Mel The table size isn’t a problem. There will be several tables that get much bigger than 8M depending on the number of subscribers and campaigns that you send.

But the number of rows suggests that you have a lot of languages in that table. When you change the admin language using the drop-down list, phplist installs the translations for that language.

image

There isn’t a way in phplist to remove translations for languages that you don’t need, you would need to use phpmyadmin for that.
You can delete rows where the lan column is ‘xx’ (the language code) except where the original column is ‘language-name’.