PHPList adds e-Mail-addresses into a list without asking for permission within a confirmation-mail

Hi everybody,

I got a strange problem. I installed PHPList and it works. I do have 3 different lists (for different languages). When I want to add my e-Mail-address to the newsletter-list “english” I put my e-Mail in the field press subscribe and I receive a confirmation-mail. If I click this confirmation-mail, my e-Mail is put into the list - like it should. Perfect until now.

When I now want to put the same e-Mail-address in another list “spanish” after pressing the subscribe-button PHPList automatically puts it in to the list without asking me anymore in a confirmation-mail to do so. Well, I receive a confirmation-mail but it does not matter, because PHPList automatically put me into the list. Probably - The reason for that is, that I already registered my e-Mail-address in another list “english”.

As an Europe-guy, I do have a problem now, because the law dramatically changed and for every subscription I need to receive a confirmation-mail first. This one I need to confirm and only then PHPList should put it into the list. If I can´t get it work like this, I am in danger of receiving letters from lawyers.

My question now is: Is it possible to change the setting (I couldn’t find until now) in a way that for every list I want to put in the same e-Mail-address I need to confirm first?
The same thing happens when deleting a confirmed e-Mail-address and immediately subscribing this mail again. PHPList automatically puts it back into the list without asking me for permission within a confirmation-mail which I receive but without sense because the e-mail-address already is registered then.

I am super-thankful for every help I can get :wink:

Thanks a lot

After totally reinstalling a brand new PHPList-System with testing it in detail, I suspect there is a little bug OR I simply cannot find the adjustments for my little problem. But I checked out every line within the config-files as well as within the tool itself. Everything seems to work fine as soon as I only do have one list. When adding more than one list the chaos starts. The same e-Mail-address will be put in the first list with asking for permission within a confirmation-mail. Cool so far. Then, when I want to put the same e-Mail-address in another list, it simple adds the e-Mail there without asking for permission anymore. That’s a big problem for me as described above. So the only way to get it working right is installing a new PHPList for every single language I offer - which right now makes 4 installations :smiley: jejeje. And I am only able to get it work right with only one list then :smiley:
Bueno - so far a little (annoying) workaround :smiley:

If there is anybody who has far more experience with handling PHPList and getting rid of my problem, please answer as soon as possible :wink:

Thanks a lot

@sunlite The confirmed/unconfirmed status applies to the subscriber, not to each subscriber/list combination separately.

You might want to try this setting

## silent resubscribe
# when someone signs up with an email address already in the database, 
# phpList will simply accept it and subscribe them as if it is the first time
# however, that allows anyone to overwrite data of someone else
# see also
# if you don't like that, you can stop this from happening and send the subscriber to the
# preferences page instead. To do so, uncomment (remove the #) the next line

To join a second list the person will need to go to the preferences page instead.

Hi Duncanc,

thanks a lot for your reply. But this does not help me really. I don’t want PHPList to send the subscriber to the preferences page. The only data I want to collect is the e-mail-address, no additional data. I like the minimalistic style. The subscriber should not do more than necessary. And necessary is only to put in the e-mail-address and pressing on the subscribe-button. More information for the subscriber is too much in my view. I want to kiis (keep it short and simple). Therefore I am also going to send HTML-emails only.
And with only one list everything is working fine. More than one list causes problems like described above - even with “Silent_Resubscribe” on. If anybody wants to subscribe for the english and the spanish version of the newsletter the confirmation-mail is only for the first time. Means: If I subscribe for the english version, I need to confirm my subscription. If I then want to subscribe for the spanisch version as well, my e-Mail-address will automatically put in the list. If I then unsubscribe for the english version and resubscribe for the english version again, PHPList again puts my e-Mail-address directly in the list because my e-Mail-address is already listet in the spanish version. Probably the e-Mail-address will only be saved once in the database. That would explain why I don’t need to confirm it for the second list. I don’t know. :smiley: jejeje. Maybe I will install PHPList for every language I offer and then I will write a little PHP-script to handle it within my page. It is a pitty that I cannot get it work with only one installation. I am pretty sure that I have overseen anything :smiley: jejeje.

For further information and tips I am very thankful :wink:
Thanks :slight_smile: