PHPList 3.3.7 not sending any Mails - no error log

Hi everyone,

last week I decided to install PHPList 3.3.7 on my Server. It is possible to subscribe and unsubscribe to a newsletter, thus the respective Emails are sent. But PHPList is not sending any campaigns or autoresponders mails at all. I just have a small test list right now.

It even doesn’t matter if I process the queue on the Admin page or via a Cron job. Nothing is send and no error log filled, even I changed error_reporting to 1 in /admin/index.php and /admin/init.php.

Also I ran the command of the cron job from the command line and allow it to create a log file. But the log file only contains “phpList - phpList version 3.3.7 © 2000-2019 phpList Ltd,
Try automatic updater here (beta)”.

Though here is what I ran from the command line, without getting any error log at all (except the above mentioned message):

/usr/local/pd/bin/php-7.0-cli /home/username/domain_name/html/eml/admin/index.php -pprocessqueue -c /home/username/domain_name/html/eml/config/config.php >~/processqueue.log 2>&1

/usr/local/pd/bin/php-7.0-cli /home/username/domain_name/html/eml/admin/index.php -c /home/username/domain_name/html/eml/config/config.php >~/processqueue.log 2>&1

/usr/local/pd/bin/php-7.0-cli /home/username/domain_name/html/eml/admin/index.php -c /home/username/domain_name/html/eml/config/config.php -p processqueue >~/processqueue.log 2>&1

/usr/local/pd/bin/php-7.0-cli /home/username/domain_name/html/eml/admin/index.php -m Autoresponder -p processqueue -c /home/username/domain_name/html/eml/config/config.php >~/processqueue.log 2>&1

/usr/local/pd/bin/php-7.0-cli /home/username/domain_name/html/eml/admin/index.php -p processqueue -c /home/username/domain_name/html/eml/config/config.php >~/processqueue.log 2>&1

And here is my config.php without comments:
$database_host = ‘localhost’;
$database_name = ‘dbname’;
$database_user = ‘dbuser’;
$database_password = ‘dbpassword’;
define(‘PHPMAILERHOST’, ‘’);
define(‘PHPMAILERPORT’, 587);//465
$phpmailer_smtpuser = ‘smtpuser’;
$phpmailer_smtppassword = ‘smtppassword’;
define(‘TEST’, 0);
$pageroot = ‘/lists’;
define(‘UPLOADIMAGES_DIR’, ‘//images’);
$message_envelope = ‘’;
$bounce_protocol = ‘pop’;
$bounce_mailbox_host = ‘’;
$bounce_mailbox_user = ‘bouncemailuser’;
$bounce_mailbox_password = ‘bouncemailpassword’;
//$bounce_mailbox_port = ‘110/pop3/notls’; //I’m not sure if this is needed
//$bounce_mailbox_port = “110/pop3”; //or even that
$bounce_mailbox_port = “993”;
$bounce_mailbox = ‘/var/mail/listbounces’;
$bounce_mailbox_purge = 1;
$bounce_mailbox_purge_unprocessed = 1;
$bounce_unsubscribe_threshold = 5;
define(‘HASH_ALGO’, ‘sha256’);

In class.phpmailer.php I set debug level to 4, but do not get any errors regarding sending messages from the queue. Do I have to make the entries from the config.php in class.phpmailer.php again? Is PHP7 the problem?

Right now I have no idea where to look especially as I do not get any error logs. Therefore I appreciate any help.

Thanks in advance.

same for me :frowning: it just stopped working.

It looks as if phplist is failing at some point. The log file should contain at least some lines similar to these if there are no campaigns to process

phpList - Script stage: 6 [0.0016970000] (182)
phpList - Finished, Nothing to do [0.0002710000] (183)
phpList - Finished, All done [0.0015600000] (189)

Yes, the big question for me is where it fails?

I even added all smtp settings to class.phpmailer.php now, but nothing changed.
Using different smtp ports, doesn’t make any difference too.
Still no logs. Even nothing is recorded in the Event Log that might give a hint.

As everything else seems to work fine, it must be around the smtp setting/phpmailer I guess.

Thanks so far.

You shouldn’t be changing any of the code. All the configuration is through config.php.
There might be a php error log, sometimes called error_log, somewhere. Try looking in the /lists/admin directory for that.

Thanks for the reminder.
But no entries in the log file from PHPList.

I changed back all entries in the class.phpmailer.php as that caused some trouble.
Now I’m back where I was with my first post.

It’s strange that nothing is written in the log file. I checked all directories that might contain a log file, but I just have the one I usually do.

@Myemlsys I can take a look if you let me have the phplist access details. Send me a private message, click my avatar to do that.

1 Like

Now PHPList works.

Just replaced all files in the /admin-directory with the original files.

Thanks for all the help!

I have the same/similar problem with sending a test campaign. I get an error saying that it failed. The errors however do show up in Log of Events under System.

Have reloaded Admin via FTP from the download that I originally used. Have checked config.php against another one that does work - no differences except for db cnnection info.
the db connection is working because I can log in.

Need to get this going. Suggestions???

As I’m not a programmer nor a PHPList expert it looks to me that it might be a good idea to upload all files again except your config files.
Maybe you compare the config.php and the class.phpmailer.php with the system that works. And as well the php.ini on both installations, just in case they are different.
Hope this helps.

I replaced the files, Also compared the config.php files – no differences. I’m beginning to wonder if the problem that people are having is with the php.ini file. or if the host is where the problem is. I’m running php v 5.6.

I really need to get this going.

Maybe you could use another PHP version. I use php 7.0 and it works.

1 Like