back to phpList.org

phpList 3.3.3 queue processing only sends 1 email every 120-130 seconds


#1

Hi everyone!!

I’m new to this forum, I hope I won’t bother you repeating topics (I searched before but nothing that I found worked)…

So, I’ve installed phpList on my own cloud server at Hetzner. They required me to do this, because you’re not allowed to send newsletter on the shared server plans. So I did that, and got everything working, Apache, MySQL, PHP 7.2.5, PhpMyAdmin… and then phpList. I was using 3.3.1 (I think) on my previous server, but when I downloaded phpList a few days ago, it was 3.3.3, so I installed that. I imported my lists and subscribers via SQL on phpMyAdmin, because phpList wouldn’t import everything right (subscribers yes, but not lists themselves).

OK, so I got everything working, but when I tried to send my first campaign (I’m doing it via browser) it was so slow… I started tweaking the config.php file, but nothing has changed. I have a batch size of 300 but it only sends ONE email at a time, and only every 2 minutes or so. So, this is my config file (comments striped):

$database_host = 'localhost';
$database_name = '******';
$database_user = '*****';
$database_password = '*****';

define('PHPMAILERHOST', '');
define('TEST', 0);

$bounce_protocol = 'pop';

define('MANUALLY_PROCESS_BOUNCES', 1);
$bounce_mailbox_host = 'localhost';
$bounce_mailbox_user = 'popuser';
$bounce_mailbox_password = 'password';
$bounce_mailbox_port = '110/pop3/notls';
$bounce_mailbox = '/var/mail/listbounces';
$bounce_mailbox_purge = 1;
$bounce_mailbox_purge_unprocessed = 1;
$bounce_unsubscribe_threshold = 5;

define('HASH_ALGO', 'sha256');
define('UPLOADIMAGES_DIR', '/lists/lists-images');

define('MAILQUEUE_BATCH_SIZE',300);
define('MAILQUEUE_BATCH_PERIOD',900);
define('MAILQUEUE_THROTTLE',2.5);
define('MAILQUEUE_AUTOTHROTTLE',0);
define('USE_DOMAIN_THROTTLE',0);
define('DOMAIN_BATCH_SIZE',1);
define('DOMAIN_BATCH_PERIOD',120);
define('DOMAIN_AUTO_THROTTLE',0);

Also, this is a snippet (Spanish) of the queue processing output:

Se procesaron 1 de 366 suscriptores
Estadio de script: 5
1 mensajes enviados en 122.66 segundos (29 mensajes/hora)
Acabada esta pasada
Se envió un tamaño menor al del lote, así que será recargado inminentemente
This batch will be 296 emails, because in the last 900 seconds 4 emails were sent
Se procesaron 1 de 365 suscriptores
Estadio de script: 5
1 mensajes enviados en 122.82 segundos (29 mensajes/hora)
Acabada esta pasada

Help appreciated!!

Cheers,
Allvoxman.


#2

I switched from browser to cronjob processing and it’s better, but still too slow: only 40-60 emails per hour, instead of the 1200 emails per hour that the config.php settings say.

Please, anything I should try??

Thanks a lot, people!