phpList 3.3.1 tracking links not functioning on Outlook 2010 mail client and some webmail clients

Campaign emails received on Outlook 2010 mail client are having “admin@” prepended to the url link.

For example:

instead of:

As a result not only is click tracking not functioning but user can’t use link to view contents in browser.

If the problem mail is forwarded from the outlook client to a web based client (eg Gmail, Hotmail, etc) the “admin@” doesn’t appear and the link is usable. If I forward a working email from Gmail to Outlook then the admin@ gets inserted when viewed in Outlook. This might indicate Outlook is somehow inserting the “admin@”.

The problem doesn’t occur on most web based clients suchs Gmail, Hotmail, Yahoo, Round Cube though I have seen the issue on a web mail client hosted on which a lot of my subscribers are on.

Has anyone else seen this issue on Outlook 2010 and any newer versions of Outlook?

Is there a workaround for this issue besides disabling click tracking?

I’ve done some further testing using the builtin Windows 10 Mail client (Version 17.8600.40525.0) as well as the current version of Thunderbird (52.4.0).

Windows 10 Mail client shows links with “admin@” prepended and gives a pop-up error (Unable to open) when link is clicked.

Thunderbird client shows links with “admin@” prepended however it is able to open links and content is displayed as expected in browser.

I tried copying the “admin@” links into chrome, edge and firefox browsers and all where able to view content.

In the case of firefox it gives a pop-up warning indicating that a login is not required into and that the site may be trying to trick you with the option to continue to site (Yes/No).

So it seems the Microsoft mail clients (Outlook 2010 and Win10 Mail) don’t like this prepended “admin@” in the tracking urls.

Why is the prepended “admin@” appearing and how can this be addressed on incompatible mail clients?

@halfmack Is this a new installation of phplist that has never worked properly? Check the value on the Settings page for web site, that might be incorrect.

Hi @duncanc, my website address setting was misconfigured with, must have been a copy/paste error when updating the settings. Corrected without the admin@ and now all working okay.

Thank you for your assistance.

PS might be worth enhancing phplist with some validation checks for the system settings entered.