phpList 3.2.5 KCFinder not working properly

Did an update on two websites with phplist: backup config.php, deleted all files, upload new ones, replaced config.php. In one website KCFinder is working properly, in the other one no thumbnails are shown and I cannot upload files. The only thing I get is a popup with (in Dutch) “Warning, Unknown failure”.

So what I did was verifying the two config files and other settings in phpList in order to find a possible problem. Nothing found. Got the feeling that this is not a problem as described in the release notes of 3.2.5. Also cleared several times the browser cache and checked with firebug if there were any problems.

One difference between the websites is that the one with the problem is https and the other one is not.

No idea what to do next. Anyone has?

@Henk_van_Dijk Which version did you upgrade from?

What is the screenshot showing - the actual problem or something else? Is the URL using https or http?

Also what do you have in the config.php file for $public_scheme?

Hi Duncanc,

Thanks for your reply.

I came from 3.2.4. The screenshot is showing one of the problems; not showing any thumbnails. The whole website is in https and so is this popup screen from KCFinder.

Don’t know what config.php you’re pointing to; the phpList config.php or the one from KCFinder. Searched in both of them for $public_scheme but could not find this setting.

@Henk_van_Dijk Your screenshot shows a “files” folder. Is that name deliberate because when you browse for an image the default folder name is “image”.

Can you try using the web console in Firefox, hopefully something similar if you are using a different browser, to see the network requests. When the browse window is open then start network tracking and refresh the window with F5. That might show something about the actual requests and their responses.

I should have referred to PUBLIC_PROTOCOL instead of $public_scheme. Are the public pages, subscribe, preferences, etc. also using https? The plugin uses that when it constructs the url for the image upload directory.

OK Duncanc,

The “files” folder got its name from KCFinder. In my attempts to get this working I emptied the folder where the imageupload takes place: uploadimages. After that KCFinder fils the folder with a folder “thumbs”, a folder “files” and a .htaccess file. All correct I think.

Tried watching the process with the web console but after pushing the imagebutton in CKEditor there are no problems shown. CKEditor though have a lot of syntax errors, but in the website where KCfinder is working fine the syntax errors are there as well. So I think there is no problem there.

Overlooked the public protocol though. The setting was http, I altered it to https. And yes all pages are working with https. But after altering this setting, logout, empty firefox cache, login, there were no improvements. Unfortunately.

@Henk_van_Dijk I can take a look at your problem if you can create an admin id for me. I think it needs to be only an ordinary admin, not a super admin.

If you are willing to do that then send the details through a private message.

OK Dancanc,

how can I send you a PM? Do you want a login for phpList only or do you want a login for FTP as well?

Was this issue resolved?

I’m having the some problem… thumbnails don’t show up and I can’t upload any images. An error message pops up:

Warning … unknown error.

This error also appears when clicking Refresh or any other button that

Tried this in both Chrome and Firefox - same error.
KCFinder is reading from a directory that is outside the Lists branch…where should these files be stored and how can the path be modified?


@falcondrum The earlier problem was caused by the use of symbolic links for some directories
For example the real path to the upload directory was


but kcfinder was deriving a different path


The latest version of the CKEditor plugin, 2.1.3+20160603, tries to workaround this problem, so firstly you should upgrade the plugin, see