back to phpList.org

phpList 3.0.12 is not sending from localhost with ssl?

My new hoster wanted me to host from the hoster’s smtp, so I changed local host to the hoster smtp and made a few lines to try to get the SSL working.

I am not getting it to work, these are the lines in the config :

 # If you want to use the PHPMailer class from phpmailer.sourceforge.net, set the following
# to 1. If you tend to send out html emails, it is recommended to do so.
define("PHPMAILER",1);

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'smtp.bhosted.nl');
define("PHPMAILER_SECURE",'ssl');
// Enter your SMTP2GO account's SMTP server.


# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
$phpmailer_smtpuser = '***********'; 
// Enter your SMTP2GO Username.

$phpmailer_smtppassword = '**********'; 
// Enter your SMTP2GO Password.

$phpmailer_smtpport = '465'; 
// 8025, 587 and 25 can also be used

define('PHPMAILERPORT',465);
define("PHPMAILER_SECURE",'ssl');

$phpmailer_smtpsecure = 'ssl'; //ssl or tls or blank

What am I doing wrong?

Thanks and greetings,

Erik.

I have tried these exact settings to Thunderbird and that is working?
Strange…

Possibly the hosting company has blocked the outgoing port.

Thanks for the answer Duncan, with the outgoing port you mean the 465 port?

In thunderbird I can use that with no problem?

Thanks and greetings,

Erik.

Presumably Thunderbird is running on your own computer not on the web server.

Hello Duncan,

Thanks again.
Thunderbird is running on my own pc not on the webserver could it be that trough the localhost blocked port 465?

Thanks and greetings,

Erik.

phplist is trying to connect to smtp.bhosted.nl. You need to ask your hosting company whether the ssl port is being blocked.

Thanks again Duncan.

I already asked that, it must be open is there a way to check it?

Thanks and greetings,

Erik.

My new hoster says that it comes trough the old version of PHPlist?

Is this possible?

Is there an errorlog in PHPlist 3.12 that I can chechk wat is going wrong?

Thanks and greetings,
Erik.

@Activate The Event Log page might have some information about any errors.

Thanks again, the eventlog as in PHPlist onlty tells me there is an error( SMTP connect failed) but not what exactly or am I at the wrong place?

Thanks and greetings,

Erik.

Because you are running a very old release of phplist the smtp debug config setting cannot be used.
You can try making the code change identified here to file admin/sendemaillib.php

and add this to the config.php file

define('PHPMAILER_SMTP_DEBUG', 3);

then send a test message.

Thanks again, it looks like it is connecting but then fails?

These are the error lines :
Connection: opening to smtp.bhosted.nl:465, t=5, opt=array ()
Connection: opened
SERVER -> CLIENT:
CLIENT -> SERVER: EHLO www.activate.nl
SERVER -> CLIENT:
SMTP ERROR: EHLO command failed:
SMTP NOTICE: EOF caught while checking if connected
Connection: closed
SMTP connect() failed.

Try a higher debug value, say 5, but otherwise I don’t really know.
I can try to connect to that mail server from my phplist and it fails, as expected, on the login

SERVER -> CLIENT: 220 smtp.bhosted.nl ESMTP
CLIENT -> SERVER: EHLO dcameron.me.uk
SERVER -> CLIENT: 250-smtp.bhosted.nl250-PIPELINING250-SIZE 41943040250-AUTH LOGIN PLAIN250-ENHANCEDSTATUSCODES250-8BITMIME250 SMTPUTF8
CLIENT -> SERVER: AUTH LOGIN
SERVER -> CLIENT: 334 xxxx
CLIENT -> SERVER: xxx
SERVER -> CLIENT: 334 xxx
CLIENT -> SERVER: xxx
SERVER -> CLIENT: 454 4.7.0 Temporary problem. Please try again later.
SMTP ERROR: Password command failed: 454 4.7.0 Temporary problem. Please try again later.
SMTP Error: Could not authenticate.

hello Duncan,

I have made a few changes ot the config and now it is working :slight_smile: 
> # To use a SMTP please give your server hostname here, leave it blank to use the standard
> # PHP mail() command.
> define("PHPMAILERHOST",'smtp.bhosted.nl');
> define("PHPMAILER_SECURE",'ssl');
> // Enter your SMTP2GO account's SMTP server.
> 
> 
> # if you want to use smtp authentication when sending the email uncomment the following
> # two lines and set the username and password to be the correct ones
> $phpmailer_smtpuser = '*****l'; 
> // Enter your SMTP2GO Username.
> 
> $phpmailer_smtppassword = '********'; 
> // Enter your SMTP2GO Password.
> 
> $phpmailer_smtpport = '465'; 
> // 8025, 587 and 25 can also be used
> 
> define('PHPMAILERPORT',465);
> define("PHPMAILER_SECURE",'ssl');
> 
> $phpmailer_smtpsecure = 'ssl'; //ssl or tls or blank

Many thanks for helping me out!