back to phpList.org

Php-allow-url-fopen is disabled on my web host - what will this break?

Hi all,

New to the forum; Scout’s honour I checked the documentation and searched the forum before posting.

I currently have v3.2.7 installed, and today wanted to upgrade to 3.5.1 to take advantage of the security fix. Installatron warned me that php-allow-url-fopen is disabled on my hosting, whilst apparently PHPList 3.5.1 requires this to be enabled.

Does anyone know what functionality will be broken by this PHP feature being disabled? I’d like to upgrade of course, but don’t want to scupper myself if the software depends on this feature for core functionality in recent versions.

Alternatively, if someone can tell me that PHPList has needed this feature since forever then I’m good to go, since it works fine for me now so clearly I don’t use the functionality that depends on the feature,

Thanks all,

Ian

@diem There is nothing new in 3.5.1 that requires allow-url-fopen. So far as I can see the only functionality that needs it is installing plugins on the Manage Plugins page, but that won’t be working for you now anyway.

Thanks Duncan, and that makes sense since the feature is used to access a remote URL.

I don’t use any plugins, nor do I intend to, so I think I’ll take a chance on the upgrade. I’ll report back with results in a few weeks after I’ve had the opportunity to exercise the software a bit.

Cheers,

Ian

Yup, seems to work fine, though Installatron wouldn’t play nice.

First of all the pre-reqs warning turned out to actually be an non-deconfigurable Will Not Continue so I had to install manually. Second a manual installation of 3.5.1 includes an .htaccess file in the main folder whose configuration prevents Installatron’s backup feature from temporarily writing a semaphore file, so I had to add the following clause:

<FilesMatch “deleteme.”>
# Apache < 2.3
<IfModule !mod_authz_core.c>
Order allow,deny
Allow from all
Satisfy All

# Apache ≥ 2.3

Require all granted

Perhaps if Installatron had worked it would’ve done this for me - I don’t know.

Either way, it works now so thanks for responding to my query!

Ian