Permissions problem on import of emails

I have been running php 3.0.5 for some time. We are moving domain so rather than just copy the database across I decided to do a clean install. Everything seems to be working fine until I tried to import the email addresses from the old system.

I then get an error


You don’t have permission to access /lists/admin/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

I have checked the permissions and they are the same as the old working system.

Any ideas?

It’s a permissions problem… you need to make sure that the index.php is readable/runable by the web process, and that .php is runnable by your web process (apache?).

did you copy over the .htaccess file? It might be ‘hidden’ in the old file system

\list\admin\index.php had permissions of 664 - I changed it to 755 and there was no change.

I did not copy over any files. I did a new install from scratch. Plan B is to copy the old files across to see if it is not a setting at the new ISP.

I did copy the old htaccess files into \lists and \lists\admin which also did not change anything so I have reverted back to the ones from the clean install

After much testing I have found that this error only occurs when I use the Subscribers/Import emails/Import by uploading a csv file.

The routine works fine until I click “Confirm Import”

What is your delimiter? I think the default is a tab.

It is a tab delimiter. The routine does run through the import file and shows no errors. I have also changed the column headings and the screen that requires you to match headings with attributes does come up and works fine in the sample screen that follows. As soon as I click Confirm import the error appears. Seems evry weird as one would expect a permission error to be more prevalent. I have checked the htaccess files. The one in the root is blank and the ones in the phplist folders are the standard ones.