back to phpList.org

Path problem with store


#1

Everywhere I enter something I go an error with NOT FOUND
The requested Url /newsletter/admin/ was not found on this server.

But when I go back everything is fine und done.

I don’t find the place where I can change this wrong path

I have — newsletter.if-meinklang.ch/admin/
and not /newsletter/admin/

I have 3.2.5 phplist working

Greetings Rainer


#2

Simply add the following to your config/config.php file
# if you change the path to the phpList system, make the change here as well
# path should be relative to the root directory of your webserver (document root)
$pageroot = ‘/newsletter’;


#3

@Dragonrider @Rlaila I think that phplist is installed in the root of a subdomain newsletter.if-meinklang.ch/admin/

so I guess that your suggestion is what he already has. If that is the case, then change it to

$pageroot = '';


#4

Thanks a lot now it is runing


#5

Hey duncanc your tip was good, but there is still a problem now I found out
for example by creating a startpage he than take the path
http://ifg-meinklang.ch/newsletter/?p=subscribe&id=1
that is wrong because the newsletter has to stand at first like
http://newsletter.ifg-meinklang.ch/?p=subscribe&id=1

where can I now change this??

Also the answer (confirm) of the newsletter has the wrong path!

Thanks for an Idee


#6

@Rlaila You might have entered the wrong value for “Website address (without http://)” on the Settings page. That needs to be where phplist is installed.

Also, there are a number of urls on the Settings page, such as “URL where subscribers can sign up”. Those might need to be changed as well.


#7

Thanks for your tip. but nothing was running. Then I decided to delete everything and to let ist install again for the server automatic from hoststar.ch Now he create the right path, all Problems are gone