Password causing 'Incorrect Password' error

I installed Phplist using Softaculous. I initially set my password as:

`lrKR5j.fw[h;x>\J;{2

Then, when I tried to log into the admin account, it gave me the ‘incorrect password’ error. However, after I changed the password to a shorter one, the error went away and I am now able to log into Phplist admin.

What’s wrong with the first password? Are there certain characters that cannot be used hence causing the error?

Any help on this matter? My current password is a very simple one and I would like to change it to a longer password with symbols but I"m afraid I can’t log in again.

@xaman I am able to change my password to your value and login successfully.

The only odd thing about that value is the \ character which gets replaced by two \ characters by phplist. But that applies to both changing the password and to logging-in with the password so is consistent.

I changed to the first password and I’m also able to log in. But first installation definitely gave an ‘incorrect password’ error. I will try another installation on a subdomain and report back.

Is there any error log that I can show here before even logging into phplist for the 1st time?

I’ve tried a fresh installation using the 1st password and it again gives ‘incorrect password’ error.

So, if I use a simple password at installation, then change to a more complex password like the one I showed at the first post works.

If anyone can tell me where to get error logs for the fresh installation when I cannot even log into phplist, I’ll post it here.

@xaman I tried with a new database and was able to login with that password. I’m copying/pasting the value, not entering it directly. But I don’t have any real idea why you are having a problem.

I’m puzzled as well. It works fine on my localhost Laragon (manual installation). But when I install on Milesweb and Racknerd using softaculous, I face the same problem with both hosting services. Something going on with cpanel or softaculous?

Edit: @duncanc Did you do a manual installation or softaculous installation?

@xaman The backslash character is the cause of the problem. phplist automatically adds slashes to $_GET, $_POST etc, so it is actually dealing with a password that has two backslashes. That works because it is consistent between setting a password and verifying that password.

But Softaculous doesn’t do that. It uses the password exactly as entered, so the password value (a hash of the password) it stores in the admin table will not match the password value entered when trying to login.

1 Like