Newsletters not going out

Just after getting my phpList working again I found when I send out a newsletter they do not go out. I can test and the test goes through fine. There are not errors listed. There is also no emails sent that confirms anything was done. Even though I have tried sending the campaign several times it is still only found in the active tab of list of campaigns. It does not show up as Sent I saved it as a draft and when I tested it to see if it was working it is now no longer in the draft tab and only in the active tab. When I place into Queue it added fine. I click process queue it appears to work but does not show processing etc so for some reason it does not send out to the ones signed up. It comes back with All done but never did anything. I am sure it is a setting not righ but have no clue as to what to check or fix.

I have also tried rebuilding indexes. I tried to initialize database but comes back table already exists. I know this issue has to do with having to reset my password and database name etc anyone know how I can change the setting so it will send out newsletter?

Thanks in advance for your time and help.
Paul

@HugATree Look on the Event Log page for any errors reported.

There are no errors listed since I have been able to send a successful test. I do not know if it tells you anything but I tested and found that if a new subscriber signs up the verification email does go out and when the verify it adds them to the subscribers’ list.

Thanks for your help so far,
Paul

When I checked the site out this morning I found a button at the top of the page that let me know there was a campaign to be sent out. I clicked on it to send it out and more when on. This time when I checked the log of events I had a bunch listed.

Processing has started,
One campaign to process.
Please leave this window open. phpList will process your queue until all messages have been sent. This may take a while
Report of processing will be sent by email
Processing campaign 129
Looking for subscribers
Found them: 20 to process
Processed 20 out of 20 subscribers
It took 02 seconds to send this message
20 messages sent in 1.68 seconds (42920 msgs/hr)
Finished this run
Less than batch size were sent, so reloading imminently

When checking it seems the campaign went out. So now the questions is how do I fix it so that when I tell it to send out a campaign it goes out and not have to wait for it to tell me I have one to send out. Strange that it can only be sent out after it has been in the queue for almost a day.

Thanks for your help,
Paul

@HugATree I don’t really understand what you are asking. If you are new to phplist then I suggest looking through the online manual particularly the section on Sending Sending | phpList manual

Ok Just like everything in my life, things that happen only happen to me. Let me see if I can explain better. I have been using phpLists for several years so I know what to do and how to fix some things.

A few weeks ago the host that I used migrated my sites to the cloud. Well when that happened names, passwords etc got changed which made the newsletter quit working. With the help of the host and another member here on the forum I found the incorrect information and fixed it, I thought. The reason I figured it was working was because before I “fixed” it when I sent a newsletter or had anyone subscribe it sent an error message saying “Error sending email to XXX.XXX SMTP connect() failed.” After the fix I attempted to send a test from the campaign screen and it went through fine and was received. I also sent in a new request to subscribe and it sent out the verification email. I submitted the verification and it added the new address to the list. I then thought it all was working fine.

Then when I went to actually send out a newsletter nothing happened. There were not reports generated, there were no error messages, and there were no newsletters sent out. I tested the same newsletter with the test feature from the campaign screens and the test worked perfectly. So I have narrowed the issue down to Finish tab of the send a campaign. I can place the campaign in the queue and it says that the campaign is queued. So up till this point it works great. when I process the queue it acts like it is doing it but only flashes on the screen then says “All Done.” Yet it did not do anything. There are no error messages and nothing at all in the Log of Events from that process. I get no email and no newsletters are sent out.

It was at this point I sent in a request for help. That was yesterday. This morning when I found you had sent me a question. I went in and checked the log of events that said no additional information. What I did find was a notice (button) on the top of the screen letting me know I had a newsletter that was in the queue and asked if I wanted to send it. (I do not remember the exact wording but you get the picture.) I clicked on to process queue. That time it went through and sent out the newsletter. So I know the system is working. There must be one command that is not set correctly but am at a loss as to what it is, where I can look, and what it should be. If I knew what file to look in and what command I am looking for then that would be a start.

Thank you very much for your time and help. I will gladly give you what ever information you need just let me know and where to find it and I will post .

Thanks,
Paul

@HugATree Sorry but it is still unclear to me what you think is not working. You have said that processing the queue worked with phplist sending the emails.

I suggest trying the process again. Create a campaign and submit it, then process the queue. If you have batch processing enabled in config.php then, depending on the size of the list, you may need to process the queue several times, once for each batch of subscribers.

Thanks for staying with me. I have tried processing several times in a row. The last one I tried only had one email address in it and still no luck. That is until the button appeared 12 hours later. The processing does work but not until I get a button at the top of the screen allowing it to complete and the button does not show up for about 12 hours later. Up until the host moved my site I would process it and it would go right out. now there is a 12 hour delay and another step to complete. I have attached a pic of the buttons I am talking about. Clicking on the button on the left will allow the process to complete. As for having the batch processing enabled in config.php I did not see that command. I saw some interesting things in config_extended.php but cannot figure out how anything would have got changed. I just do not know what I am looking for to fix.

Thanks for your continued help and time. Maybe the picture will help you understand how the only way I can process my queue. I can send you the files if you want to see them. Just let me know which ones.

Thanks
Paul

@HugATree Possibly your new server is in a different time zone to where you are. You can check that on the Scheduling tab which shows the server time, not your local time. The embargo field shows the time when the campaign will be eligible to be sent by phplist, and also affects whether the “Process the queue” button is displayed, as in your screenshot.

If this is the problem then you can install the Timezone plugin, then set your time zone. The embargo time then should be treated as in your time zone,not the server’s. Go to menu Config > Manage Plugins and follow the “find plugins” link to find it.

Ok. Found the problem. If you do not know how to fix then that is ok. At least I know how to make it work. I guess when they moved the files to the cloud it caused the server time and the embargo time to get all messed up. The program automatically sets the embaro time to be the future. So I have to manually change it with each campaign I have to send out. I never thought to check it because the server time is Eurpoe time and I am in the USA so it was never my time anyway.

Lol I was just typing this when u sent the message

Thanks for the info and I will see if I can fix
thanks again
paul

Well this is what I have come up with. I could not find a Timezone plugin but I did see a place in config.extended.php dealing with time zone. I set it to define(‘SYSTEM_TIMEZONE’,‘America/New_York’); using the instructions above the define line. The one step I cannot figure out is

// You will also need to tell Mysql about your timezones, which means you have to load the timezone
// data in the Mysql Database, which you can find out about here:
// MySQL :: MySQL 8.0 Reference Manual :: 4.4.4 mysql_tzinfo_to_sql — Load the Time Zone Tables

But I contacted my host and am hoping they will fix the Mysql settings for me. Just thought others reading this thread might find all this information helpful.

Thanks again for your time and help. If they cannot fix it at least I still have a way to make it work

Paul

If you followed the link that I mentioned

https://resources.phplist.com/plugins/start

Ok. Thanks. Found it with that link. If my host cannot set it on the server to match what I have done in config_extended.php then I will try that.

Thanks for your time and effort.
Paul

@HugATree You change only config.php, not config_extended.php, that is explained at the start of config.php.

Thanks I missed that part. Now I got it all loaded but would not let me enable it because said the commons plugin was not enabled. I found the commons plugin and tried to enable it but I received this message. “Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.1.0”.”

Ok. now after getting help with my host I finally got my site back up. I will not be able to use the plugin because I cannot enable the commons plugin because if i go to php7.1 it crashed another program i run that will not use that high of a php version. So there i be stuck in the middle. i will just have to change the time myself each time i go to send a newsletter

thanks for your help and i wish you all well.
paul