New bug? Content tab will not save what I input

-I am on latest Chrome but tried this on MS Edge too.
-Was on phpList v 3.1.? but then upgraded to latest 3.2.5 hoping that would help. Upgrade went fine but I still have the problem described below.
-Server is LAMP hosted

This list had been working fine for years. Last used in June and was OK but now a problem. No changes have been made to the server in the interim that I know of…but it is a shared hosted environment so who knows what undocumented changes might have happened.

I enter a message in the Content tab, just like always, and click Next and it dumps me to the homepage of my site, not the Text tab as expected. When I go back through and look at the campaign again nothing was saved. I tried clicking “Save as draft” and “Save and continue editing” but get the same thing: dump and no save. Same thing also happens if I click on the Text tab.

If I copy the URL for tab 2 then I can paste it in a new window and I can get to it. From there I can enter as usual in tabs 2 through 6 but it tells me in 6 “message content missing”. So, this is specific to the Content tab.

Any suggestions?

You might want to make sure your php version on the server is the latest version. (5.5.x?)

PHP Version= 5.5.32
MySQL Version = 5.5.45-cll-lve

I was able to work around and send an important campaign by going directly into the MySQL database and entering my html content in the table for a record of the draft campaign that had already been created. Then the rest of phpList worked and I was able to get through all 5 other tabs and hit the send button.

Another odd thing that happened, and it may have been due to the workaround, was that the send button I got the message “Campaign added” but then it did not show up in the Active pane in the list of campaigns. It stayed in Draft and would not send. So I had to click on the View Campaign button in Draft to view it and at the bottom there was a button that said “Resend”. I hit that and then it actually goes into the queue and would send.

Does this sound like a bug or a problem with my installation. If with mine what might have caused it to start in a system that has been working for years?

@ashoc Sounds similar to an earlier problem.
Do you know whether a reverse-proxy is being used?

I had misread this, so your issue doesn’t look too similar to the other one. Can you use chrome developer tools to look at the http requests and responses?
The browser should send a POST then the response should be a 302 that redirects to something like this

Hi and thanks for your help.

No, it doesn’t seem to be similar to the other one. I don’t think there is a reverse proxy.

FYI, the link that you gave sends me to a malware site.

I am not quite sure how to see the requests and responses. I have Chrome Developer Tools up but under which menu should I be looking?

@ashoc The network tab shows the requests and responses. You need to open the tool then go through the steps that cause the problem.

The link that I included was only an example of what you should look for, with the domain obscured.

OK, I understand now.

Name Status Type Initiator Size Time
?page=send&id=166&tk=a599338a5 302 text/html :1 195 B 523 ms 304 document 101 B 155 ms
xxx.css 200 stylesheet (index):5 (from cache) 21 ms
xxx.png 200 png (index):140 (from cache) 15 ms

So I think this shows that it sends a 304 and gets a 302 back, right?

@ashoc You want to look at the response, particularly the Location header. That should be identifying the next tab to be displayed.
Also, what values do you have for “web site address” on the Settings page, and $pageroot in the config.php file?

OK, I am not familiar with how Chrome Developer works so was not aware of the info hidden. Got it now. Below is a copy of the sections that you show above:

Request URL:
Request Method:POST
Status Code:302 Found

Response Headers
Content-Type:text/html; charset=iso-8859-1
Date:Wed, 19 Oct 2016 23:39:05 GMT

On the Settings page Website Address = (i.e., the same address that is coming up as “Location:” above). In config.php we have “$pageroot = ‘/lists’;” and that is the correct path relative In other words, If I type “” then it does bring me to my phpList main subscribe page.

If I right-click on the “2 Text” and click “Open link in new tab” then the Text Tab opens just fine. If I then click the “Next” button in that tab then it works fine and brings me to the Format Tab. Below is the post and response for that click:

Request URL:
Request Method:POST
Status Code:302 Moved Temporarily

Response Headers
Cache-Control:no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Date:Thu, 20 Oct 2016 00:01:20 GMT
Expires:Thu, 19 Nov 1981 08:52:00 GMT

@ashoc On the step that doesn’t work, in the developer tool scroll down a bit to the Request Payload section. That should have a followupto field that identifies the destination tab. What is the value, or is it missing?

There is no Request Payload section and no followupto field.

@ashoc Can you let me take a look by signing-in to your phplist? Send me a personal message (click my name/image) with the access details, if you want me to do that.

OK, I am trying to create an admin login for you and I get the email and click to open the page and put in a new password for you. When I put in the password and then click on “Continue” I get the same behavior; it crashed to the homepage of the domain.

Same thing happens on a bad login attempt.